Rdp from windows fails

I know this sounds like a well known problem with defined solutions, but I am unable to connect to the xavier NX from windows 10 using RDP. I get a screen with the NVIDIA logo but then the session dies without traces. I searched the web and tried all possible solutions I could find so far including the hints for vino (vncviewer stops with message that the connection has been closed manually). I was able to connect via rdp to the Jetson Nano dlinano image, so it must be a configuration issue on the xavier. Any hint is appreciated
Ciao, Mathias

I had tigervnc-scraping server working on Xavier R31.1.

But NoMachine also works between Xavier, TX2, Ubuntu host, Windows10 host… You would download and install the ARM8 deb package.

Also note that it may expect a display available, so you would have to either login locally on Xavier so that user runs the GUI, or set this user’s option as auto-login so that a display is available after boot. I haven’t been able to find other solutions, but some more skilled user may share about this. It was required for VNC or x2x, at least, not sure for NoMachine, but I’d suggest you first try with a GUI session opened.

[EDIT: If not wanting to use user auto-login, it is possible to start x server from ssh using /usr/bin/startx and wait for a few (say 10) seconds. You may have to add beforehand this file (otherwise you may have to cancel 16 times):


polkit.addRule(function(action, subject) {
 if ((action.id == "org.freedesktop.color-manager.create-device" ||
 action.id == "org.freedesktop.color-manager.create-profile" ||
 action.id == "org.freedesktop.color-manager.delete-device" ||
 action.id == "org.freedesktop.color-manager.delete-profile" ||
 action.id == "org.freedesktop.color-manager.modify-device" ||
 action.id == "org.freedesktop.color-manager.modify-profile") &&
 subject.isInGroup("{users}")) {
 return polkit.Result.YES;


I tried NoMachine and am impressed by the ease of the installation and use! Excellent advise!
I installed the ARM8 Deb package. The installation had no error or warning. Installing NoMachine under windows is the same. The Xavier NX was detected automatically as it runs on the same LAN. I still need to play a bit with the screen resolution but the performance is perfect.
Ciao, Mathias