Warning when I loaded a usd created from an urdf


I used an urdf and created an usd with it following this tutorial. Before saving, I modify the collision to use a convex decomposition as I do not want to use the convex hull for the collisions.

When loading my usd afterwards, I get the following warning:
[Warning] [omni.physx.plugin] PhysicsUSD: Parse collision - triangle mesh collision (approximation None/MeshSimplifixation) without SDF cannot be a part of a dynamic body, falling back to convexHull approximation: /World/envs/source_env/obj_0/obj_0_base. To enable SDF collisions, sdfResolution should be > 0.

The collisions seem to be converted to convex hull. How could I have collisions with the convex decomposition and not the convex hull and load it as I wish with those collisions? How could I avoid at the same time this warning just above?

Hi @alempereur - Someone from our team will review and respond to your question.

did you try using our URDF importer?

Otherwise, what you are missing is changing the collision type from Triangle mesh to something else. The physics engine does not support using the direct mesh or mesh simplification for rigid bodies as that would be too costly in the broadphase collision detection. if you can’t use Convex Hull for whatever reason, the next best option would be Convex Decomposition, and then tune the decomposition parameters until you find a satisfactory collision group that works for you.

When I use the urdf importer and save the usd using the convex decomposition, then when I import the usd again, the problem occurs.