Why the document can't be download?

  I want to download the latest document about TX2, but when I go to the download page I can't download any 'pdf' document. What about the server?

If you are referring to the “Technical Reference Manual” (TRM), then I think this is still being worked on. The TX1 TRM actually has a lot of information compatible with TX2, e.g., all of the controller base addresses and register sets which are common among both are exact matches.

If you tried to download without logging in first (e.g., using wget), then you need to log in first.

Thank you for your reply! But I’m of course a member of the forum and I have the right to download the document! These document such as ’ Jetson TX2 Module Data Sheet’, When I open the link, a ‘pdf load error’ is jump out and I can’t get the document! Who meet the same question like me and how to solve it? Thanks a lot!

Who can open this link? http://developer.nvidia.com/embedded/dlc/jetson-tx2-module-data-sheet

Try clean cache, use another browser.
The link is fine,as it seems to me

I use many browser and two PC to open the link, but still the error! Can you send me these document to my email? Thank you a lot!
I need http://developer.nvidia.com/embedded/dlc/jetson-tx1-tx2-developer-kit-carrier-board-spec
http://developer.nvidia.com/embedded/dlc/jetson-tx1-tx2-interface-comparison-and-migration
http://developer.nvidia.com/embedded/dlc/jetson-tx2-module-pinmux
http://developer.nvidia.com/embedded/dlc/jetson-tx2-module-data-sheet

My email is zuohaorui@sina.com

You say “But I’m of course a member of the forum”. Have you registered as an nvidia developer? That is not the same as registration for this forum, unfortunately. It really should be the same but it isn’t, it is a different log in. To join, you need to create a nvidia developer login by filling this out:

https://developer.nvidia.com/developer-program/signup?downloadable_file=876171

and then responding to the email it sends you. After registration is complete, you should be able to log in and access the documents. You will have 2 logins, one for being a “nvidia developer” and one for this forum login.

It works for me, but I have to log in first. As @ESJS mentioned, this is a separate login…even if you are logged in to forums you are not logged in to documents. For example, go here and log in first (or register) before going for that PDF link:
https://developer.nvidia.com/embedded/downloads

I’m always can’t download these doucuments. When I hit the link, I receive a blank web page! Like below!

http://developer2.download.nvidia.com/assets/embedded/downloads/secure/tx2/Jetson%20TX1-TX2%20Developer%20Kit%20Carrier%20Board%20Specification/Jetson_TX1_TX2_Developer_Kit_Carrier_Board_Specification_v20170501.pdf?wDOWnvbEnX74VBTuzm1NuG6NKBxAy9q8tjxBqjILPkdAd-XQLGuqJ3qCtzYcv3IHj18b6CPvz7SDeAr_s82HvZbvCOBN9T6p43HfFpvTA4ROKFVnMLQuDzN9hWlXdUzOR4a58h8J2NGW6fDTiZGp8ECpXoXbTNsltSt7V8e_eo5tertNF1VLKuIiQCmp59rawjbTqJL_oQ0xv-HrglTBSuf8HaUOAarP-AnkaYms08C9sxelDp8XNUewnUCshTTiDDu7NRxt0oKvfweGhOEbstqqedzlB2i5E8OjVS8zZpvg5u-teldPkqnYalxk8zk

Hi Richardzhr,

I have no idea with this. But for http://developer.nvidia.com/embedded/dlc/jetson-tx1-tx2-developer-kit-carrier-board-spec , I will be redirected to this link (http://developer2.download.nvidia.com/assets/embedded/downloads/secure/tx2/Jetson%20TX1-TX2%20Developer%20Kit%20Carrier%20Board%20Specification/Jetson_TX1_TX2_Developer_Kit_Carrier_Board_Specification_v20170501.pdf?Nm4e8L-WElcEPVElCWnLGrE44U_XUMdKDq19SfR0FXkPIUhie2LgOK6Rjj_LWshKyli_cuOVvUgK_I4Tqkah42Z2E1GBrtG6SR3u1guiIgTuYtBo9_o8bZd3mT3vmOagcr9Ku8Bsayq8tSrke4bNDADkiauNRgN3qdKh2TYLuXw9sF2t2X_7jjP0dh15WyzLR-upq9Hw8UDfY4EmHseCH81_YIuL6OnJorems7Ua8wRJpZtopk_bOvyoiRaoiNE7XCeHamv_p0_rtaOIY2u95yz-8b_r_xlGnMm4Lhirh2DvJyP2D1vv96kYMTt4704). Could you try with it?

Test this link…if it fails, I’d have to wonder if you are using a proxy or something different is going on for your side since it works for me (and there is nothing special about my connection):
https://developer.nvidia.com/embedded/downloads

Also, which browser do you use, and if it shows up blank, can you “view source” and see if source is blank?

Yes, It’s blank! Anyone can send me the latest documents which published on 1 May. My email is zuohaorui@sina.com. Thank you very much!

It’s always blank! Can you send these latest documents which published on 1 May to me? My email is zuohaorui@sina.com. I find these documents for a long time!

I’m with you! Such a PIA to have to “register” 49 1/2 thousand times for different locations all in nVidia.

Such a PIA to have to “register” 49 1/2 thousand times for different locations all in nVidia.

They are slowly integrating these. geforce.com will merge with nvidia.com soon, for example.