Some documents on Download Center download fail

For example, I tried Jetson TX2 OEM Product Design Guide

http://developer.nvidia.com/embedded/dlc/jetson-tx2-oem-product-design-guide

It shows HTTP 501 error. I tried on different web browsers, Chrome, IE, Edge. All the same.

Anyone had this same problem?

the link seems to require authorization

once authorized the document is easily accessible

You do need to log in there separately from forums (this is a separate register of user name). I was able to download the document once I was logged in, but the http 501 error code would not be related to being logged in or not. Are you able to reach this link, and if so, can you log in or register for logging in:
https://developer.nvidia.com/embedded/downloads

If there is still an error try deleting cache…if you go through a proxy you may need to delete cache on the proxy.

My download page is not error but blank! The link is http://developer2.download.nvidia.com/assets/embedded/downloads/secure/tx2/Jetson%20TX2%20OEM%20Product%20Design%20Guide/Jetson_TX2_OEM_Product_DesignGuide_v20170501.pdf?LU0B1SECcBLBzu56TMRTdudg4tBeE_2HXs-UrtvTwg5ZeuSnazYybWNdts6zUkyDBZ4BB5l_AOcngkgkVgxg1otP-cT9X2okPtn3ndKXdcf2cFoK6qoD4k3nq4eU4VNbjoqsRlUgRJKcerg0w7FnSv7Mt7Uk7nzLp9jDQB9Z-XKKnNrLxqF2j-2XscM9gGCHmSEYMDC6fMFNiWUcnK-_cKVtY3tjn3xNIARpn7zjnVyParrnIvbK0FbSpc4--xjwtIw.
When I view source the source is blank too! How to fix it?

Do be aware that the above URL goes to a “page not found” failure…the page should not be blank; however, the page also does not lead to a valid URL (only error messages show up). The URL https://developer.nvidia.com/embedded/downloads is the one which should present a login (a login requiring a different registration and password than the name/pass for the forums). This URL is an SSL encrypted page, so if the browser is blank, I wonder if perhaps there is an error related to SSL as well as cache (I don’t know what would happen when mixing a cached page and SSL).

I can access the link you provided.
I did log in to the download center. Actually I’ve downloaded some of the packages there without problem, like the Jetson 3.0 (JetPack-L4T-3.0-linux-x64.run). And for those I could, I can still download now.
Is there any further level of authorization needed, like a membership to a certain program? I’m currently registered in NVIDIA Developer Program and GameWorks Regsitered Developer Program.

hi Richardzhr, so I’m not alone here. You are probably using Chrome. If you use IE, you’ll see the 501 error page.

One observation I have, is that, all the links I cannot start download have whitespace (%20 in its HTML form) in the URL, while all the links I can download have not.

Sounds like you go through a proxy that doesn’t correctly implement URL escaping then.

Try replacing %20 with + and see if it works.

hi snarky,
I tried your suggestion, still no luck. Now it’s 403 page not found

Latest report, I set up a proxy before downloading, now it works. That proxy is mainly for evading the great fire wall in China. I never thought I have to use it to download files here, since the nvidia developer site is not blocked like youtube or facebook.

Any way, for anyone having similar problem, consider using/changing a proxy.

Thank you all a bunch!