Xavier nx is not visible from sdk manager

Dear Nvidia lovers,

1, Nvidia xavier nx micro usb device id 0955:7e19 was not in the list generated by command lsusb.
2, The usb device id 0955:7e19 is not in the file at /var/lib/usbutils/usb.ids.
3, Online at http://www.linux-usb.org/usb.ids the id 0955:7e19 is not included either.
4, tried manually, failed too. I think it is because the xavier was not recognized in the first place.

Please help
thank you very much

Was the NX in recovery mode? Basically, short the recovery pin and ground pin, then bring up power or reset power.

Just for related trivia, “0955” is the manufacturer ID of NVIDIA as a member of USB.org. The “7e19” is a device ID, and not all device IDs are listed with USB.org within the known list of NVIDIA devices. The trick is that the driver package on the host PC will look for “0955:7c19”, but other software will probably have no understanding of that ID.

Thank you linuxdev,
I believe NX was in recovery mode! I followed (the manually way) the instructions very carefully. I tried many many times. But I don’t have a way to verify that NX was in recovery mode other than follow the instructions carefully to its completeness. I do hope there is a way to verify the NX is recovery mode.

If the host pc cannot see the NX from usb connection, then weather nx is in recovery mode or not will not be available to sdk manager. Please let me know if my view on it is wrong.

Thank you for your effort for solving my problem…

Hi,

My suggestion is you could check the serial console too. If device is in recovery mode, it should be totally no response.

You could firstly power on the device, verify it really boots up (you shall see logs on serial console) and then put it to recovery mode. After putting it to RCM, there should be no log and no response to any of your input.

After that, plug the micro usb cable and check lsusb. If you still cannot see it, then switch to another host or other usb cable.

Are you using VM on host machine?

1 Like

Thank you WayneWWW. My problem was solved.
I followed your guide, verified the RCM mode. Then found the usb cable was bad.
After replacing the cable, lsusb command listed the Nvidia device ('0955:7c19`).
The SDK Manager detected the device too.

(I am not using VM on my host machine)

Great help, thank you again