2x2 Mosaic with top 2 screens rotated 180

I have 4 displays that I want to arrange in a 2x2 mosaic. I have 4 P4000 and I can establish a mosaic no problem, and it works really well.

Except. My top two displays are installed upside down. I had thought that I would be able to just rotate them in Windows, and if I’m not in Mosaic, then I can. And it works great. But when I configure and turn on Mosaic, the top two screens revert back to normal landscape orientation.

I’ve done a lot of digging online and it doesn’t seem to be something that’s supported??? I got the command line configuremosaic.exe tool, and when I dump the settings I can see a rotation setting on the individual displays, but the only setting is to rotate them all.

Sigh. This is not something that I thought I’d be spending hours and hours trying to work out.

Hello,

Unfortunately, this cannot be done with Mosaic alone. You will need Warp and Blend on top of Mosaic to achieve this.

https://developer.nvidia.com/warp-and-blend

Best,
Tom

Hello,

I am having the same problem. After setting each individual display on Nvidia control panel by rotating, I used mosaic 2x2 2rows 2columns. When the mosaic completes setup with big single screen, upper two displays revert to original landscape position.

I have surfed hours searching any hint to evade this bug with no success. Upon seeing this page, I got warp and blending page and looked carefully into their MP4 videos, the last one was a bit helpful, the rest were just too abstract showing no use. Nvidia site does not give you any hand on examples of valuable use.

I got to the point that configuremosaic is not going to solve the problem. So I have to write everything in NVAPI.h file.

The problem is " how do I run my programmed NVAPI?

Do I have to complie? or specify path or

I just want to know how I can use of this NVAPI staff.

Thanks

Hi,

I’m looking into similar problems.
Does anyone have an example on how to do this?
I have 2 vertical screens, where one is rotated 90° CW and the other is rotated 90° CCW.
Unfortunately the mosaic utility is not able to solve my problem.

I’m guessing you need to open it as a visual studio project.