After initial setup, Jetson Nano went completely dead, bricked

I carefully went through the startup, powered by a micro USB. Everything went fine, I setup the image onto the SD card, loaded it, went through the initial setup, created password, etc.

Then immediately after logging in for the first time, it went dead.

I’ve since purchased and tried a barrel jack for power, nothing.

I’ve tried to reconnect the micro USB, nothing

I’ve removed and put back the sd card, nothing

With the mircoUSB connection the light will turn on for a second then turn off. With the barrel jack there is no response at all. I tried removing the sd card and putting it back in, removing the HDMI and putting it back in.

I’m lost as where to go next, please let me know. At this point the device appears totally bricked, I cannot get any response other than the light coming on for a second.

At this point I don’t know what else to do.

Since this post I have tried the following:

  • Started the device in recovery mode (pins 9 and 10)
    This caused the light to stay on, but no other noticeable affect, the screen is blank, no image, it’s as if it’s not connected at all, this was with micro USB power

  • reset the device, same thing, the light stayed on, but no other noticeable affect

  • initiated power on (pins 11 and 12), nothing happened

I’m running out of ideas here, the last thing I saw was a login screen where I logged for the first time, I pressed enter and then nothing, it was as if it went dead right then and there, since then other than the light being on sometimes, there is no evidence the device is even running.

IF anyone out there has any ideas, please reply, I have tried everything I can think of.

I’m going to wait til the end of the day, but without any progress my only move left is replacement. I’m just concerned a replacement is going to take me right back here. I don’t get it, I followed the instructions to a T

I also tried all the above things with the barrel jack as the power source, still nothing, force recovery mode keeps the light on, but that’s it, nothing ever shows up on the screen, it’s otherwise dead. Other than the light no evidence that it’s even on.

Final Update, I also tried

  • reflash the sd card, no change,
  • start in recovery mode
  • start in system reset mode

None of these caused any noticeable affect, other than the light staying on when in recovery and reset mode. The screen still shows nothing, as if the device is not even on.

Nothing comes on the screen at all.

Any suggestions are appreciated, I have done everything I can think of.

Ever since the first time logging in, the device has been inoperable, other than the light turning on and off, there is no evidence it’s even doing anything at all.


Welcome to the forums!

I have moved this thread over to the proper forum for you. In the future please post Jetson issues in the Jetson category.


Thanks for moving this, please let me know what steps I should take, the power light comes on only for a second or two and then off.

I tried putting in the recovery pins, this causes the light to say on, but when I connect the usb to my computer nothing shows up for ls /dev/cu.usbmodem*

If anyone has any suggestions at all, please let me know

I’m out of ideas

What do I do now that I am in force recovery mode (I think), I don’t have anyway to confirm.

Nothing in the docs I saw explained what to do when you get to forced recovery mode.

Again, it won’t boot, the light just turns on for a second and off.

I saw people posting logs from their devices that won’t boot does anyone know how I can produce these logs, where do I go what do I do?

I’m really trying here.

I would love some assistance.

Hi mikepland,

Are you using the devkit or custom board for Jetson Nano?
What’s your Jetpack version in use?

Please refer to the following instruction to capture serial console log if you are using the devkit.
Jetson Nano & NX Style - Serial Debug Console - JetsonHacks

Also want to confirm, I notice one key comment here…

Again, it won’t boot, the light just turns on for a second and off.

Are you talking about the LED on the board just light up and then directly goes off?

The point here is, if you can still see the LED shown on the board, please follow KevinFFF’s suggestion here to dump the log.

If you totally cannot see the LED light up, please check the power source you are using there…

BTW, I notice you filed 3 topics all talking about similar things… please just choose one topic to reply. It didn’t hep to ask multiple times…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.