AGX Orin Forgot Password

Hello, its has been a while since anyone in my lab has tried to enter our Jetson AGX Orin. Therefore, no one remembers the password. Can anyone please advise what is the best way to recover this password. Thank you in advance!

Use SDK Manager to re-flash the device.
I don’t think there is anyway you can recover the password.

Do you have any links to detailed instructions on how to do so? We tried to use a usb stick earlier to re-flash but nothing happened. I may be doing something wrong.

https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/index.html

Is it possible to resolve my issue through force recovery instead?

I’m not sure what you mean here.
The only way is to re-flash the device.

Recovery mode causes the Jetson to behave as a custom USB device which is understood by the custom driver…which happens to be in the flash software. Unless you flash with the mentioned method recovery mode will have no effect (rebooting a recovery mode Jetson leaves the original Jetson).

You could perhaps find information on cloning in the docs if you have anything you need to save.

I am using automatic setup for “recovery mode setup” however, it seems that the host machine is not detecting the AGX Orin that is connected via usb c. Anyway for me to check the connection or troubleshooting tips you might have? I am using Ubuntu on VM Virtual box also. Not sure if that is causing any problems.

You need to use manuel setup when the device is not booting correctly, and you need to press buttons correctly to put the device in force recovery mode.

Don’t use virtual machines, please.

Ok, got it. I stopped using a VM and now my host machine can see the Orin. However, when I try to flash, I get this error. Not sure how to resolve this:

Put the log here.
We don’t know anything from this picture.

You might also want to state if any security fuses were ever burned (you’d know if you did this; I mention it because it would stop flashing of the non-rootfs/boot content when a wrong/custom signature is used; default is a NULL signature which is what a default flash uses).

1 Like

I was able to manually reboot, thank you!