Brand new AGX ORIN 64gb dont boot

Hello everyone,

Please I need help.

I just receive today a brand new Jetson AGX Orin 64gb.

I have read this : Getting Started with Jetson AGX Orin Developer Kit | NVIDIA Developer

It just don’t boot, I see this screen and it go back full black, fan working at low pace and I can ping the jetson

I’ve seen this too :

But can I have an explanation please, I’ve paid 2 398,80€ for this baby and why it just don’t start up ?

I work since a long time now with Jetson Nano and never got any issue (Of course Nano need to be flashed at first use.)

Thanks in advance.


Please prepare another x86 ubuntu 18.04 or 20.04 host and install sdkmanager on your host.

Then use sdkmanager to flash your jetson orin.

Btw, jetson nano requires to get flashed by sdkmanager too.

Thanks for the answer,

Btw, jetson nano requires to get flashed by sdkmanager too.

Well, no, for the nano I just flash the *.iso file from Windows.

I will try ok, but now, why a brand new board doesn’t boot?


Sorry that I cannot answer that. Actually I always suggest any user needs to flash any kind of jetson product with sdkmanager in the first time you get it.

If you only need to update sdcard image on jetson nano and never tried sdkmanager before, then you are lucky enough that you didn’t break the system before.

Wow, its little scary…break the system???

Its time to do some update on NVIDIA website guys I think, no??


Since it is embedded system, it is common that someone accidentally breaks their bootloader or something else.

For example, lots of users try to write their own kernel driver too.
It is easy to break system if the kernel driver leads to system crash. For those cases, it is common to reflash the system.

Jetson nano is more like a beginner level product which can run with sdcard image. But any AGX series products (Xavier AGX/ Orin AGX) is unlike nano. It does not run with sdcard image. Thus, needs to flash the board in the first time.

Ho, I just see

18.04 or 20.04

And of course my main Ubuntu is 22.04.03… Everything is great…


Can work on Live USB ?

Ubuntu 20 Live will work if the kernel supports loopback. “Probably” it does (I haven’t tried)? The main trick is that you need about 50 GB of disk space formatted as ext4, so you can’t for example run this on an NTFS or VFAT partition.

Incidentally, Jetsons don’t have a BIOS, and all of the equivalent is in software (for the AGX Orin it is in partitions). This is why Jetsons cannot self-flash. The Jetson becomes a custom USB device in recovery mode, and part of the flash software running on the host PC is the “driver package” (named well since it is the driver to that custom USB device). In a way you are updating the equivalent of the BIOS when you flash, and not just bootloader and o/s.

1 Like

That’s a great and clear answer.

Thank you very much, reinstalling 20.04 right now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.