Can not flash Orin AGX “Reading board information failed”

I believe I am having a similar issue to those described here and here for which there is so far no concrete solution.

After booting the Orin for the first time and following the getting started guide. I made it to this point where I rebooted the device:

sudo apt update
sudo apt dist-upgrade
sudo reboot

I have since been unable to get a display output or seemingly properly boot the device. On the BIOS screen I see a ** WARNING: Test Key is used.** error before losing display output (Jetson UEFI firmware version 2.1-32413640).

I have since tried to remedy this by booting into recovery and re-flashing the Orin with SDKManager but I am getting a Reading board information failed error. I can see the Orin as Bus 002 Device 003: ID 0955:7023 NVIDIA Corp. with lsusb and have tried both USB2 / USB3 ports as well as different USB cables on a Ubuntu 20.04.5 LTS x86_64 system.

Any help would be much appreciated. I spoke to customer support ref 230301-000327 who suggested I ask for additional support here, I have also attached the SDKManager flash and /dev/ttyACM0 boot logs below:
orinflash.log (9.8 KB)
orinminicom.log (11.2 KB)

Hi matousjk,

From your serial console log, it seems stuck at MB2.

Are you using devkit or custom board?

Could you also provide the SDKM log for further check?

Hi @KevinFFF,

Yes I’m using just a regular devkit, this is last thing I can see before losing display output:

I attached the output of running sudo ./ jetson-agx-orin-devkit mmcblk0p1 as per the docs here to my original post, these logs look the be the same as those from SDKM which I’ve also attached below just incase:
sdkmoutput.log (5.5 KB)

Are you sure the device side log is a repeatable log in every flash attempt?

@WayneWWW Yes I’ve consistently been getting the Reading board information failed error. over multiple flash attempts

While I’m not using the massflash workflow or a custom board I believed this thread could be relevant since I believe there is something wrong with the EEPROM. I tried manually specifying the BOARDID=3701 FAB=TS4 BOARDSKU=0004 BOARDREV=A.0 which they are using for their AGX Orin to remove the need for reading board data out of EEPROM but this fails to generate an image.

Please understand my question. I asked the “device side log”. Not host side log.

@WayneWWW I’m not sure I understand what you mean, running minicom -D /dev/ttyACM0 -8 -b 115200 while attempting to flash does not generate any logs.

Yes, I mean turn on your minicom and monitoring what gets printed after you run on your host pc.

If there is no log printed, then I don’t think that is due to broken eeprom. Please try to use a ubuntu 18.04 x86 host to flash and see if that can work.

Okay that’s what I was doing and I didn’t get any logs.

I have since tried using a Ubuntu 18.04.6 LTS x86_64 Kernel:5.4.0-84-generic to flash and it looks like I’m getting exactly the same error. Logs are attached below:
ubuntu18flash.log (8.0 KB)


Could we make sure that this host machine is able to flash any other jetson orin device first?

Also, please do not use rel-34 anymore. It is just DP. No need to use it to check any issue.

Unfortunately I only have access to one Jetson device of any kind. I have tried using multiple hosts / ports / USB cables all of which yield the same result.

Flash issue is always cross check. If there is no method to test, then we can only suggest to RMA.

Thanks for the help @WayneWWW, I have initiated an RMA with support.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.