Can not ssh to xavier nx with ip address 192.169.0.x

Just want to reopen this case.

I have a Jetson Xaiver NX and a Windows Laptop, both connected to home WIFT and I use putty/WinSCP from Windows to login to NX. The ip addresses of all device is like 192.168.1.x.

I recently changed my home WIFI names (SSID). I After this, I restarted my NX, connected to the name WIFI names with new passwd and could go online without any problem. I used “ifconfig -a” to find the new ip address of Xavier NX. I noticed that the ip addresses of all device changed to 192.168.0.x.

On my Window machine, I also connected to new WIFI SSID and go online without any problem. However, I could not ssh from my WIndows to NX with putty or WinSCP.


The router determines the IP address. Unless you’ve set it to do so, I think many of them default to a 192.168.0.x subnet. However, that behavior can also usually be modified by an admin login to the router itself (you’d have to consult the manual for your particular WiFi on how to do that). If both the Windows machine and the Jetson migrated to a 192.168.0.x subnet, then I’d think it would “just work” unless there is firewalling involved (likely on the Windows side).

Did the Windows box also get the new 192.168.0.x subnet for its IP address? If not, then you’d have to figure out some form of bridging or forwarding to cross subnets.

As linuxdev mentioned, sounds like it should just work. Does it connect to the internet at all? If so, instead of manually having to SSH, you could use Edgeworx Cloud. We did a write up on how to do it here. This should bypass your need to use any specific IP address and does not require it to even be in the same room/house/state/country as long as it is connected to the internet.

I could not make it work. So I decided to to change my router settings to give my devices the ip address 192.168.1.x. After that, ssh worked fine.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.