Capture Images from Camera and display inference on saved images

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

Good Evening everyone,

I’m back on Drive AGX Xavier subject in my company. For a reminder we are trying to use a Camera (Leopard Imaging AR0231) to capture images. We’d like to run an IA model of our own to detect traffic signs, lights etc.

For that we’ve followed the procedure to install the drive AGX Xavier but we still have several issues:

  1. No Desktop
    We’ve read several threads (on this forum) on the subject about gdm3 desktop but haven’t been able to run correctly with gdm3 the desktop on the drive AGX.
    We’ve been able to use a desktop with slim but as soon as we do a sudo apt update it screws everything and we have to reflash the drive AGX

  2. Run Drive OS without GUI in command line
    We’ve tried also to run without desktop the Drive AGX also without any luck …

  3. Running nvsipl camera on the target and not on host
    We’ve been able to run the nvsipl_camera with ssh from the host. But we’ve not been able to do the same thing directly on the target. (Using slim) We don’t understand why.

Help will be really appreciated on these differents topics, it becomes the top priority of the company. We’ve just flashed the drive AGX and we’re able to try anything.



Regarding the desktop issue, it seems you’ve already looked into forum threads, and I’m glad to see your proactive approach. You can indeed find valuable information and potential solutions in the forum. Please follow Not able to view screen in drive pegasus - #2 by VickNV to explore possible resolutions for the desktop problem.

For the other issues you’ve mentioned, such as running Drive OS without a GUI and running nvsipl_camera directly on the target, I recommend creating separate topics for each of these in the forum. This approach will make it easier for the community to assist you with each specific issue and provide more focused support.

Thanks again for the quick answer as i said earlier we’ve tried the different approach concerning the desktop. And we’re ok with every solutions that are listed here. But we’re not able to get any command line (tty3 or 4) using CTRL + ALT + F3/F4

Do you have any topic i may have missed on the subject ?

Even without installing a desktop we’ve got not screen with the CLI.

For the samples on the target i will make another topic.

Thank you so much for the time


Reflashing your system is a good step to consider. Before proceeding with the desktop installation, it might be beneficial to test some sample applications, e.g. Camera Replay Sample, on different monitors to determine if the monitor is functioning correctly. This can help identify and address any underlying issues before proceeding further.

Hi Vick, Monitors is functionning we’re using it every day ! We’re also using it when calling the sample by ssh.
We’ve reflashed the drive AGX but we’re still un able to get any console on screen.

We have to use the SSH to interact with the AGX.

We’re really stuck on this subject.



I suggest trying different monitors on the devkit to clarify the compatibility issue and make sure Camera Replay Sample works on your monitor before installing gdm3.

We’ve already try that with different monitors and nothing seems to work if we are trying to work on the target. If we run samples through ssh it’s working perfectly

Dear @brieuc.daniel,
Could you check Error trying to connect monitor - #17 by SivaRamaKrishnaNV.
Please share the steps you have followed while enabling GUI for verification.

Please share the error details if you encounter any.

Hi @SivaRamaKrishnaNV,

We just tryied once more your link Error trying to connect monitor - #17 by SivaRamaKrishnaNV .

We’ve reflashed only on Xavier A following the first message and link.

We’ve activated x server with the command

$ sudo -b X -ac -noreset -nolisten tcp

and you may find in the attached files the result:

first_start.txt (11.6 KB)
nv_aurix_update.txt (180 Bytes) (406.4 KB)

We’ve tested on three different monitors and its always same the issues.

Thank you very much for the time !


Dear @brieuc.daniel,
Did you install ubuntu desktop package as in ? I expect display to come up after this.
From Install DRIVE with SDK Manager :: DRIVE Platform Installation Guide with NVIDIA SDK Manager , only 3a or 3b needs to performed. Is it the issue?

Hi @SivaRamaKrishnaNV,

No we didn’t install ubuntu desktop package we’re trying to get the console without desktop. And we only did the 3a for the same reason.


Sorry for coming back this soon but we really need help on this subject but we really need to get this cracked we’re going to some conventions and we really need a demo with the drive AGX.


Dear @brieuc.daniel,
Could you share the error log when you run nvsipl_camera sample via ssh?

We don’t have any error using nvsipl_camera with ssh That’s the problem we’re not able to run it directly on the drive AGX but it’s working with ssh

Dear @brieuc.daniel,
Do you get output display when running via ssh?

Yes we do ! This is why it’s really surprising

Dear @brieuc.daniel,
So, you could run the command via ssh and notice the output window is coming without any issue.
we didn’t install ubuntu desktop package we’re trying to get the console without desktop

If not ssh, how you want to access the console when ubuntu desktop is not installed? You want to run the app in CTRL+ALT+F3 virtual console? Is CTRL+ALT+F3 accessible?

Yes it’s exactly what we are trying to do but ctrl+alt+F3…5 is not working

But we’ve got in debut console this error message :

verify_rate_range: FMON_NVDISPLAYHUB: rate 2781250 below min 18750000
fmon_update_config: FMON_NVDISPLAYHUB: detected fault 0x4000

You 'll find the dmseg log in attached files
dmesg.txt (12.3 KB)

Dear @brieuc.daniel ,
So you can not open the virtual terminals, right? AFAIU, virtual console is part of ubuntu desktop features. That is not related to DRIVE OS Linux kernel and supposed to be working.

So do you advise us to install finally ubuntu-desktop and gdm3 ? How to run it the nvsipl_camera sample after that ? We’ve already tried but weren’t able to make it run