Crash while launching Isaac Sim

Hi,
https://docs.nvidia.com/isaac/isaac_sim/quickstart.html
I am referring to the above page. When I run Isaac sim with the following command line I am seeing a crash window pop up.
I submitted my crash report in the dialog window but I would like to fix this ASAP.

./Engine/Binaries/Linux/UE4Editor IsaacSimProject CarterWarehouse_P -vulkan -isaac_sim_config_json="<FULL_PATH>/apps/carter_sim/bridge_config/carter_full.json"

I changed the <Full_PATH> to my working directory. My system is as follows

CPU: Intel quad core i5
Memory: 8 GB RAM
GPU: GTX 1080i

I can upload my crash report log if you need this.

crashreport.log (236 KB)

Hi,

Please upload your crash report, is hard to say what happened withit.

As I ran the following command lines, I could not launch carter_sim. I had succeeded in launching it for the first time but I cannot do it right now.

bazel run apps/carter_sim:carter_sim – --config=“apps/assets/maps/carter_warehouse_p.config.json” --graph=“apps/assets/maps/carter_warehouse_p.graph.json”
crashreport.log (236 KB)

I attached my crashreport.log file when I ran the following command line
bazel run apps/carter_sim:carter_sim – --config=“apps/assets/maps/carter_warehouse_p.config.json” --graph="apps/assets/maps/carter_warehouse_p.graph.json

which part is not working the Isaac Sim side or the Isaac SDK app side?

when you run
./Engine/Binaries/Linux/UE4Editor IsaacSimProject CarterWarehouse_P -vulkan -isaac_sim_config_json="<FULL_PATH>/apps/carter_sim/bridge_config/carter_full.json"

The UE4-based Isaac Sim should open.

And when you run the cartersim app on the Isaac SDK side, the simulation should start.

Which step is not working for you?

Sorry for the confusion. Currently carter_sim part is working as I changed my command line with absolute path of carter_full.json

Isaak SDK side is not working so I attached crashreport.log file when I ran the following command

bazel run apps/carter_sim:carter_sim – --config=“apps/assets/maps/carter_warehouse_p.config.json” --graph="apps/assets/maps/carter_warehouse_p.graph.json

It seems like the connection is not made. Did you also changed the path inside the graph and config json file?

See Setup paths section in the document:
https://docs.nvidia.com/isaac/isaac_sim/quickstart.html#setup-paths

Yes, I changed the paths inside the carter_full.json as follows
{
“graphs”: ["/home/tripod/projects/Isaac_sdk/apps/carter_sim/bridge_config/carter_full_graph.json"],
“configs”: ["/home/tripod/projects/Isaac_sdk/apps/carter_sim/bridge_config/carter_full_config.json"]
}

when you run
./Engine/Binaries/Linux/UE4Editor IsaacSimProject CarterWarehouse_P -vulkan -isaac_sim_config_json="<FULL_PATH>/apps/carter_sim/bridge_config/carter_full.json"

Does the UE4 opens and you see a Carter robot in the warehouse?

Do you run the
bazel run apps/carter_sim:carter_sim – --config=“apps/assets/maps/carter_warehouse_p.config.json” --graph="apps/assets/maps/carter_warehouse_p.graph.json

in another terminal, while the UE4 is open?

When I run
./Engine/Binaries/Linux/UE4Editor IsaacSimProject CarterWarehouse_P -vulkan -isaac_sim_config_json="/home/tripod/projects/Isaac_sdk/apps/carter_sim/bridge_config/carter_full.json"

I can see UE4 opens but I cannot see a Carter robot in the warehouse.

I run
bazel run apps/carter_sim:carter_sim – --config=“apps/assets/maps/carter_warehouse_p.config.json” --graph=“apps/assets/maps/carter_warehouse_p.graph.json”

in another terminal, while UE4 is open but I see the same message in the crashreport.log I will attach my screen shot file if you need this.

If you don’t see the Carter robot in the warehouse, either your paths are not correct, or the the pose in the “/home/tripod/projects/Isaac_sdk/apps/carter_sim/bridge_config/carter_full_config.json” is not correct.

The correct pose for Carter in warehouse is “pose”: [1, 0, 0, 0, -11.01, 63.47, 0.92]

Pose is correct as follows

“A_CarterGroup”: {
“ActorGroup”: {
“actors”: [
{
“name”: “carter_1”,
“reference”: “Blueprint’/Game/Carter/VehicleRigs/Pawn_Carter_FirstPerson.Pawn_Carter_FirstPerson’”,
“pose”: [1, 0, 0, 0, -11.01, 63.47, 0.92]
}
]
},

The following is the path to carter_full.json when type pwd in the terminal

tripod@issac:~/projects/Isaac_sdk/apps/carter_sim/bridge_config$ pwd
/home/tripod/projects/Isaac_sdk/apps/carter_sim/bridge_config

Once UE4 opens did you press the play button?

When I click play button I can see people walking around in the warehouse. While I am launching 1ocalhost:3000 my computer becomes too slow and I am stuck with stopped screen.

Do you think this is why my system does not meet your requirements?

CPU: Intel quad core i5
Memory: 8 GB RAM
GPU: GTX 1080i

After rebooting my computer I did the above procedure you mentioned and I can see people walking around in the warehouse and the proper Isaac Sight at localhost:3000.

However, I pushed printscreen to capture screenshot and my computer became too slow again. I am stuck with stopped screen again.

I tried to lower the frame rate but it is too slow and I am stuck with stopped screen.