Issac Sim 2020.1 Running Natively ./_build/linux-x64_86/release/isaac-sim.sh fails

Hi, I am trying to run Issac Sim locally, but when I call ./_build/linux-x64_86/release/isaac-sim.sh I get the following error. Does anyone have an idea of what the problem is?, Thanks!

[Info] [carb] Logging to file: /home/aescape/NVIDIA-Isaac/isaac-sim-2020.1/_build/target-deps/kit_sdk_release/_build/linux-x86_64/release/data/Kit/isaac-sim/2020.1/omniverse-kit.log
2020-08-05 03:12:05 [0ms] [Warning] [omni.kit.app.plugin] [Graphics API] Vulkan

Starting Manip Extension
terminate called after throwing an instance of ‘pybind11::error_already_set’
what(): SystemError: <built-in method contains of dict object at 0x7fc4ed57e438> returned a result with an error set
./_build/linux-x86_64/release/isaac-sim.sh: line 4: 17020 Aborted (core dumped) “$SCRIPT_DIR/…/…/target-deps/kit_sdk_release/_build/linux-x86_64/release/omniverse-kit” --config-path "SCRIPT_DIR//experiences/isaac-sim.json" @

Hi, welcome to the Forums!

Could you please provide the steps to reproduce the error and your system settings like Ubuntu OS version and output of nvidia-smi?
Also, have you installed and ran Isaac SDK too?

One thing to try is to run ./setup_python_env.sh before running ./isaac-sim.sh

Thank you for your soon response. I tried ./setup_python_env.sh before running ./isaac-sim.sh and the output is the same:

[Info] [carb] Logging to file: /home/aescape/NVIDIA-Isaac/isaac-sim-2020.1/_build/target-deps/kit_sdk_release/_build/linux-x86_64/release/data/Kit/isaac-sim/2020.1/omniverse-kit.log
2020-08-05 19:22:44 [0ms] [Warning] [omni.kit.app.plugin] [Graphics API] Vulkan

Starting Manip Extension
terminate called after throwing an instance of ‘pybind11::error_already_set’
what(): SystemError: <built-in method contains of dict object at 0x7f93ca0b2438> returned a result with an error set
./isaac-sim.sh: line 4: 30579 Aborted (core dumped) “$SCRIPT_DIR/…/…/target-deps/kit_sdk_release/_build/linux-x86_64/release/omniverse-kit” --config-path "SCRIPT_DIR//experiences/isaac-sim.json" @

The output of nvidia-smi is:

Wed Aug 5 15:15:11 2020
±----------------------------------------------------------------------------+
| NVIDIA-SMI 440.100 Driver Version: 440.100 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce RTX 208… Off | 00000000:65:00.0 On | N/A |
| 27% 35C P8 4W / 250W | 641MiB / 11016MiB | 7% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 1467 G /usr/lib/xorg/Xorg 409MiB |
| 0 1714 G /usr/bin/gnome-shell 122MiB |
| 0 2630 G /opt/teamviewer/tv_bin/TeamViewer 6MiB |
| 0 19382 G …AAAAAAAAAAAACAAAAAAAAAA= --shared-files 97MiB |
±----------------------------------------------------------------------------+

Thanks, Looks like your GPU and drivers are good.
Do you get the same error running as a local windowed container? Steps here.

No, the container works fine.

The error could be caused by your environment and I’m not able to reproduce it. More info about your setup would be helpful.
Going forward, can you use the container instead?

I also meet a problem when I run ./_build/linux-x86_64/release/isaac-sim.sh
It shows :
"2020-08-18 06:22:43 [1,341ms] [Info] [carb] Initializing plugin: rtx.scenedb.plugin (interfaces: [rtx::scenedb::SceneDb v0.6]) (impl: rtx.scenedb.plugin)
2020-08-18 06:22:44 [1,736ms] [Info] [carb] file ‘/home/jhw/isaac-sim-2020.1.1920-4b1097bc-linux-x86_64-release/_build/target-deps/kit_sdk_release/_build/shaders/rtx/scenedb/SparseMemCopy.compute.hlsl’ does not exist
2020-08-18 06:22:44 [1,736ms] [Info] [carb] file ‘/home/jhw/isaac-sim-2020.1.1920-4b1097bc-linux-x86_64-release/_build/target-deps/kit_sdk_release/_build/linux-x86_64/release/cache/Kit/2020.1/6488-251eba22-release/shadercache/72d2b3aec31a324ac5aee83cb1863b14.spirv.desc’ does not exist
2020-08-18 06:22:44 [1,736ms] [Info] [carb] file ‘/home/jhw/isaac-sim-2020.1.1920-4b1097bc-linux-x86_64-release/_build/target-deps/kit_sdk_release/_build/shaders/rtx/scenedb/SparseMemCopy.compute.hlsl’ does not exist
2020-08-18 06:22:44 [1,736ms] [Warning] [rtx.shaderdb.plugin] The file ‘/home/jhw/isaac-sim-2020.1.1920-4b1097bc-linux-x86_64-release/_build/target-deps/kit_sdk_release/_build/shaders/rtx/scenedb/SparseMemCopy.compute.hlsl’ does not exist.
2020-08-18 06:22:44 [1,736ms] [Error] [rtx.shaderdb.plugin] Cannot load shader file ‘rtx/scenedb/SparseMemCopy.compute.hlsl’.
2020-08-18 06:22:44 [1,736ms] [Error] [rtx.scenedb.plugin] createContext error: Failed to initialize rtx::scenedb::Context
2020-08-18 06:22:44 [1,743ms] [Error] [carb.scenerenderer-rtx.plugin] Failed to create rtx::scenedb::Context.
2020-08-18 06:22:44 [1,743ms] [Warning] [carb.renderer.plugin] Failed to create context for scene renderer ‘rtx’.
2020-08-18 06:22:44 [1,743ms] [Error] [carb.renderer.plugin] No carb::scenerenderer::SceneRenderer was found.
2020-08-18 06:22:45 [2,894ms] [Error] [omni.kit.plugin] Startup Error
2020-08-18 06:22:45 [2,894ms] [Error] [omni.kit.plugin] Unable to create renderer. Make sure you are running with an NVIDIA GPU supporting RTX Ray Tracing with a minimum of 6GB GPU memory, and a recent driver.
2020-08-18 06:22:45 [2,894ms] [Error] [omni.kit.plugin] carb::renderer::createContext failed.
./_build/linux-x86_64/release/isaac-sim.sh: line 4: 3833 Segmentation fault (core dumped) “$SCRIPT_DIR/…/…/target-deps/kit_sdk_release/_build/linux-x86_64/release/omniverse-kit” --config-path “SCRIPT_DIR//experiences/isaac-sim.json" @”

what can I do to solve this problem.
waiting for your reply

hongwei

[Info] [carb] Logging to file: /home/titanxp/Downloads/isaac-sim-2020.1.1920-4b1097bc-linux-x86_64-release/_build/target-deps/kit_sdk_release/_build/linux-x86_64/release/data/Kit/isaac-sim/2020.1/omniverse-kit.log
2020-08-18 12:14:23 [0ms] [Warning] [omni.kit.app.plugin] [Graphics API] Vulkan

2020-08-18 12:14:24 [854ms] [Warning] [rtx.shaderdb.plugin] The file ‘/home/titanxp/Downloads/isaac-sim-2020.1.1920-4b1097bc-linux-x86_64-release/_build/target-deps/kit_sdk_release/_build/shaders/rtx/scenedb/SparseMemCopy.compute.hlsl’ does not exist.
2020-08-18 12:14:24 [854ms] [Error] [rtx.shaderdb.plugin] Cannot load shader file ‘rtx/scenedb/SparseMemCopy.compute.hlsl’.
2020-08-18 12:14:24 [854ms] [Error] [rtx.scenedb.plugin] createContext error: Failed to initialize rtx::scenedb::Context
2020-08-18 12:14:24 [984ms] [Error] [carb.scenerenderer-rtx.plugin] Failed to create rtx::scenedb::Context.
2020-08-18 12:14:24 [984ms] [Warning] [carb.renderer.plugin] Failed to create context for scene renderer ‘rtx’.
2020-08-18 12:14:24 [984ms] [Error] [carb.renderer.plugin] No carb::scenerenderer::SceneRenderer was found.
2020-08-18 12:14:25 [1,336ms] [Error] [omni.kit.plugin] Startup Error
2020-08-18 12:14:25 [1,336ms] [Error] [omni.kit.plugin] Unable to create renderer. Make sure you are running with an NVIDIA GPU supporting RTX Ray Tracing with a minimum of 6GB GPU memory, and a recent driver.
2020-08-18 12:14:25 [1,336ms] [Error] [omni.kit.plugin] carb::renderer::createContext failed.
./_build/linux-x86_64/release/isaac-sim.sh: line 4: 6143 Segmentation fault (core dumped) “$SCRIPT_DIR/…/…/target-deps/kit_sdk_release/_build/linux-x86_64/release/omniverse-kit” --config-path "SCRIPT_DIR//experiences/isaac-sim.json" @

Hey, I am facing the same problem as well.

And here is my setting :
Tue Aug 18 14:16:38 2020
±----------------------------------------------------------------------------+
| NVIDIA-SMI 440.100 Driver Version: 440.100 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 TITAN Xp COLLEC… Off | 00000000:01:00.0 On | N/A |
| 23% 38C P5 21W / 250W | 306MiB / 12194MiB | 1% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 1611 G /usr/lib/xorg/Xorg 18MiB |
| 0 1699 G /usr/bin/gnome-shell 51MiB |
| 0 2711 G /usr/lib/xorg/Xorg 120MiB |
| 0 2844 G /usr/bin/gnome-shell 108MiB |
| 0 4003 G /usr/lib/firefox/firefox 3MiB |
±----------------------------------------------------------------------------+

Hi, I am facing the same issue too. By running the Isaac Sim 2020.1 with local hardware.
Hope for responsive technical support!

Hi Hongwei, please post the output of nvidia-smi. I think you might not have the correct drivers or GPU. Please see our minimum requirements.

Hi Aquib. The Titan Xp is not supported for Isaac Sim 2020.1. Please use an RTX card such as Titan RTX, RTX 2060 or better.

oh,I know. My GPU is GTX1060.