Error when flashing Jetpack 5.1 on Jetson [Reading board information failed]

I want to flash Jetson Orin with developer Kit to Jetpack 5.1. On the jetson is JetPack 6.0, but is for my current task to “new”.

I tried both with SDK Manager and manual with -xcript both fail with same error.

For Flashing I use a native Ubuntu 18.04 x86 as host maschine.
Build OS is in both cases fine and I can see Jetson device under lsusb
as Nvidia Corp APX with number 0723.

The log is attached, the first error is when reading the rcm file. Many other errors accure including the USB-Timeout (I did the echo -1> /sys/…/autosuspend).

flash.log (7.9 KB)

Make sure you follow every steps mentioned here correctly:

Like you need to unplug & plug in the USB-C cable again, and also put the device in force recovery mode again.

1 Like

I did fresh plug and set jetson in forced recovery Mode.
On Host with Ubuntu 18.04:

root@kevin:~# cat /sys/module/usbcore/parameters/autosuspend 

When applying binaryies of Jetson Linux 35.1 with JetPack 5.02, everything seems fine

kevin@kevin:~/Downloads/Linux_for_Tegra$ sudo ./
Using rootfs directory of: /home/kevin/Downloads/Linux_for_Tegra/rootfs
Installing extlinux.conf into /boot/extlinux in target rootfs
Root file system directory is /home/kevin/Downloads/Linux_for_Tegra/rootfs
Copying public debian packages to rootfs
Start L4T BSP package installation
QEMU binary is not available, looking for QEMU from host system
Found /usr/bin/qemu-aarch64-static
Removing QEMU binary from rootfs
Removing stashed Debian packages from rootfs
L4T BSP package installation completed!
Disabling NetworkManager-wait-online.service
Disable the ondemand service by changing the runlevels to 'K'

When jetson normally powered:

root@kevin:~# lsusb
Bus 002 Device 003: ID 0955:7020 NVidia Corp.

When jetson in forced-recovery-mode (sudo reboot - f forced-recovery)

root@kevin:~# lsusb
Bus 002 Device 004: ID 0955:7023 NVidia Corp.

But still the error log remains the same, when running

root@kevin:~/Downloads/Linux_for_Tegra# sudo ./ jetson-agx-orin-devkit mmcblk0p1

flash_sh.log (8.0 KB)

After printing [ 0.2927 ] Sending bct_br the process waits for a few seconds, before the rest is dumped and the flash process is aborted.

I could Flash the jetson.
I thought with sudo reboot - f force-recovery it was in recovery Mode, but i wasnt able to Flash.
I followed now the unpowered steps from here and i can flash

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.