GIE cannot be installed on device?

Hello!

I was flashing Jetson TX1 with JetPack 2.3.1 but got some trouble, on Ubuntu 14.04. Here are the messages:

Error: GIE cannot be installed on device. This may be caused by other apt-get command running on device when installing GIE. Please use apt-get command in a terminal to make sure following packages are installed correctly on device before continuing:
libgie1 libgie-dev

I tried to use ‘sudo apt-get -f install libgie1 libgie-dev’ but it didn’t work, I got messages like ‘Unable to locate package libgie1’ etc. Can anyone please tell me how to solve it? or should I try another version of JetPack?

Hi Kogepan,

Please edit the following file:
/etc/apt/sources.list
To add the line as below:
deb http://ports.ubuntu.com/ubuntu-ports/ xenial-updates universe
Update the package list by executing:
$ sudo apt-get update

Jetpack3.0 is live, if you still got trouble with JetPack2.3.1, please try JetPack3.0 also. Thanks!
https://developer.nvidia.com/embedded/dlc/jetpack-l4t-3_0

still in trouble:(

W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-updates/universe/binary-amd64/Packages 404 Not Found [IP: 91.189.88.150 80]

W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-updates/universe/binary-i386/Packages 404 Not Found [IP: 91.189.88.150 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

it seems to do not include binary-amd64 or binary-i386 folder in /universe, anything else could i try besides download JetPack 3.0?

Hi Kogepan,

Please refer below topic:
https://devtalk.nvidia.com/default/topic/957632

Nope, that didn’t work for me
still got error ‘404 Not Found’
upset:(

I do notice the failing GET is for desktop architectures (both 64-bit and 32-bit compatibility). I’m wondering if the host has the prerequisite NVIDIA GPU? And just to verify, was it intended that you were wanting to install those packages on host, not Jetson?

Does that mean I should execute all this commands on Jetson instead of my computer?(on VMware,visual machine)

JetPack runs on the desktop host (JetPack cannot run on the Jetson). JetPack can install various packages to either host or Jetson. In the error case you mentioned above it was trying to install to host, not to Jetson, which is why I ask. Double check what packages and architecture are selected if it wasn’t the desktop PC you intended to install to.

Thanks a lot! I have already installed all standard components on my TX1.
But I get another problem:
Does CUDA-8.0 toolkit for L4T includes Nsight?
I noticed that the CUDA toolkit documentation said ‘Nsight Eclipse Edition is installed as a part of the CUDA Toolkit package’ and only tell you how to install CUDA toolkit.
I have checked /usr/local/cuda-8.0/bin, there are some other files but no nsight.

I have a Fedora host so I manually install packages (no JetPack for me). I do not know if CUDA install (via JetPack) to host also installs nsight or not, but I suspect it does because nsight is in the subdirectory of “/usr/local/cuda-8.0/bin/”.

I got Nsight on my host, but I’m not sure if it was installed by JetPack(I used to run ‘apt-get install nsight’ on my host)
What I want to question is, if I want to compile on TX1 instead of via host to cross compile, is there any IDE I can use?
Sorry for so much questions, cause I’m totally a freshman about it:(

Once you have the repository enabled for CUDA it’ll know about what provides nsight.

Nsight does not run on the Jetson. There are several “general use” editors which work, e.g., “juffed” works. At times I have also used nedit. I think “kate” also works, but it’s heavy weight and large footprint. It would be interesting to hear what people use for native Jetson editors when nsight cannot be used.

I believe nsight has the ability to run on host but remote build and edit on the Jetson which would allow avoiding cross-compile environment setup, but I have not done this (my version of nsight has an ssh bug where the crypto algorithms are built in to nsight and anything requiring secure access will reject those algorithms…meaning newer Ubuntu and Fedora will reject that version of nsight). There was supposed to be a newer version coming out, but I don’t know if this was just for the x86_64 systems (it’s marked for CUDA 9 and currently Jetsons only support CUDA 8…I’ve not heard of any plans related to CUDA 9). See:
https://devtalk.nvidia.com/default/topic/988099/nsight-eclipse-edition/is-ssh-private-key-remote-access-broken-in-cuda-8-0-nsight-/

I have never tried Eclipse (still looks very complicated to me) on tegra, but I have been using QtCreator on TK1, it is probably available on TX1 as well.
It provides editor with syntax color, build options, and can be used as front-end for static code analysis, debugging with gdb, memory checking with valgrind.
I have never tried nor heard about gpu extension for being used as front-end for gpu tools, but it doesn’t mean it doesn’t exist.