How come when I export from Blender, my holes are half filled

I made a cylinder, with a hole at the bottom so I could use it as a container that drips.

I used Box Cutter plus a Solidify modifier, and I applied all the transforms using ‘Visual Geometry To Mesh’.

When I open the file in Omniverse, I get a hole that is half filled.

Does anyone have any idea why the hole isn’t still a hole when I open it in Omniverse?


I don’t know what else I need to do to get this import into Omniverse correctly.

Thank you

I uploaded the Blender file if anyone smarter than me knows how to get this into Omniverse correctly.

CylinderWithHole.blend (824.3 KB)

I sort of found a work around, and that is to cut my object in half in Blender, ,and put it back together in Omniverse using Merge Mesh.

This worked, but wasn’t as good as having a single piece.

Hi @DataJuggler! Check out this post and see if it helps! Blender hidden object - #4 by makowalski

Hi @DataJuggler This is a known issue rendering concave polygons in Hydra. One workaround is to triangulate the mesh prior to export, by applying the Triangulate modifier to avoid concave polygons. Just FYI, the next Blender release will have an option to automatically triangulate the mesh when exporting to USD.

Thank you. I will try that.

Triangulate modifier worked. Thanks again.

I thought I heard Nvidia is working on something that is a live sync between Blender and Omniverse? Is something like that coming that will be more than just import / export?

Yes, we’re working on a connector add-on that will support Import/Export directly with Omniverse Nucleus servers and Apps. As a part of that connector we will include Live Sync features with Blender to Omniverse apps, much like you see with Maya/Max and Omniverse. More updates will be announced when we get closer. Stay Tuned!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.