Isaac sim 2020 remote server deployment problem


I’m trying to deploy Isaac sim 2020.1 EA on a remote Aliyun server (located In China). The server configurations are shown as follows with command ‘nvidia-smi’:
| NVIDIA-SMI 440.100 Driver Version: 440.100 CUDA Version: 10.2 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 Tesla V100-SXM2… Off | 00000000:00:08.0 Off | 0 |
| N/A 35C P0 54W / 300W | 0MiB / 16160MiB | 1% Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| No running processes found |

I tried to deploy isaac sim using container. However, the image pulling speed is extremely slow. I gave this up after 2 day’s pulling. So, my first problem is 1. Is there any solution that can speed up the pulling process?

Besides, I tried to run natively on the remote server using the command ’ ./isaac-sim-2020.1.1920-4b1097bc-linux-x86_64-release/_build/linux-x86_64/release/ --allow-root’. However, the error occurs as follows:

So, 2. Is there any solution to address this error?

Many thanks!

Hello, and welcome to the IsaacSim community. I am not an expert in the problem you describe, but I suspect the Python environment is not right. The difficulty in configuring the environment is a major reason why we offer a containerized solution. It can be very difficult to debug this sort of problem. I will consult with engineers who might have insight into your situation.

Hi Qin,

Issue #1
If it is possible, could you try running it on a server located in different location, maybe the US? You could also try using a VPN connection to the US?

Issue #2
Could you please post a log with a -v flag to the command? This could produce more verbose logging that help us narrow down the problem.

Thanks for your reply! I’ll try to switch to the containerized solution.

Hi, thanks for your reply.

I have tried to use a VPN, unfortunately had no obvious effect.

The log with a -v flag is shown as follows:

However note that the error is not the same as the previous post. I cannot reproduce the previous error probably because I have installed all the dependencies that Isaac SDK requires.

That error indicates that the GPU is not supported. We currently recommend running on an RTX series card such as a 2060 and above or a Tesla T4.

For running on the cloud, currently we support Amazon EC2 with the Tesla T4 GPUs.

Understood. Thanks!