Jetpack 4.6.2 and Jetson TX2 NX

Hi,
we have a problem trying to flash the JP4.6.2 on a Jetson TX2 NX installed on a custom carrier board.
We tried using the SDK Manager getting the flash error:

UnicodeDecodeError: 'utf-8' codec can't decode byte 0xa4 in position 15: invalid start byte
--- Error: Reading board information failed.

After several attempts by changing the SDK Manager configuration parameters which all led to the same result, I tried to open a console and use the nvautoflash.sh script manually.
Both the commands
sudo ./nvautoflash.sh --print_boardid
and
sudo ./nvautoflash.sh
led to the same error message.

To exclude any eventual HW issues we tested the operations described above on different boards previously working.

Is this an installer bug?
We are using the latest SDK Manager v1.8.0.10363

UPDATE 1: We tried flashing the JP4.6.1, same error.

UPDATE 2: The same problem is present in the previous SDK Manager v1.7.2.9007

UPDATE 3: We can flash the board manually by using the command
sudo ./flash.sh jetson-xavier-nx-devkit-tx2-nx mmcblk0p1
so there is something wrong in the nvautoflash.sh script used with the TX2 NX module

Thank you
Walter

For custom design caarrier board, to use flash.sh is the correct way, it can’t be flashed via the SDK manager directly.
The SDK manager is for devkit.

If the SDK manager is for the devkit, why does it provide options to flash the modules not installed on the devkit?
However, this problem is only with the TX2 NX modules, Xavier NX module on the same carrier board can be flashed without any problem.

That sometimes issue witl the board config, usually custom design board is suggested to use the flash.sh, you can refer to the L4T doc for more information: NVIDIA Jetson Linux Driver Package Software Features : Flashing and Booting the Target Device | NVIDIA Docs

1 Like