Jetpack CUDA install issues

I’m new to the Tk1. I finally got the Jetpack to install.

When I try to run some of the Cuda examples, like when I tried to run randomFog, it says:

./randomFog: error while loading shared libraries: cannot open shared object file: No such file or directory

In the cuda-l4t directory, if I run cuda-l4t, I get:

dpkg-split: error: error reading /home/ubuntu/cuda-l4t/: Is a directory
dpkg: error processing archive /home/ubuntu/cuda-l4t/ (–install):
subprocess dpkg-split returned error exit status 2
Errors were encountered while processing:
Ign file: InRelease
Ign file: InRelease
Ign trusty/multiverse Translation-en_US
Ign trusty/restricted Translation-en_US
Ign trusty/universe Translation-en_US
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package cuda-toolkit

Did something not get installed properly?

Is there some way to kick off a rebuild of the libraries on the device?

When I run, it seems like it is working but doesn’t display anything other than the counters in the top right corner and the control in the top left.

You should reinstall L4T via JetPack, although you may want to delete the existing JetPack files on your local machine to avoid anything that might have been problematic on the last JetPack flash session.

There will be an update to JetPack next week, so you may want to wait for that instead, however.

Is there some way to do that without erasing everything I’ve already done on my install?


Clone the root partition, “re-use” that during a flash. See:

Note that you can loopback mount this and edit, e.g., copy from this to the sample rootfs, or the other way around.