JETPACK issues. Cannot install or uninstall host components

I have the following messed up issue.
I tried to uninstall all components of Jetpack 4.4, however the uninstallation failed. Now When i go to uninstall, it says “No SDKs are installed”. But when I try to install them, it shows that all components are installed.

I am stuck now and unable to move forward or backwards, I can’t uninstall or remove anything to make a clean install and i cannot install either.

Hi dailami,

Sorry for the inconvenience. Can you please attach the ~/.nvsdkm/sdkm.db file for more investigation?
To workaround the issue, please use following steps:

  1. mv ~/.nvsdkm/sdkm.db ~/.nvsdkm/sdkm.db.bak
  2. sudo rm -rf ~/nvidia/nvidia_sdk/JetPack_4.4*

I have attached the file. I had to rename and add th gz extension to comply with the rules of the forum. Just remove the extension

sdkm.db.gz (600 KB)

Thanks dailami,
I checked this file and found there is no JetPack 4.4 installed in it. The uninstallation is clear.

Could you please provide a screenshot for this?

Here are the screenshots

Thank you dailami,
This is expected results. As the host components are all debian files, SDK Manager will detect whether they already exist on your host. If they exist, they’ll be marked as installed. However, we could see that the target components are not installed yet.
You could still go on installation (by checking “I accept the terms and conditions of the license agreements” check box then continue) and flash your device.

I am trying to install Cuda and the other host components. the Jetson components aren’t my issue for now.

Is there a workaround for this?

Hi dailami,

The CUDA and other host components already exist on your machine. For example, you could run “dpkg -l | grep cuda” command to list all cuda packages installed on your host. If you do want to clean them with SDK Manager, you could select host components only, then continue installation with SDK Manager. After installation is finished, you’ll be able to use SDK Manager to uninstall them.

doing this brings an instant message that it was successfully installed, but no changes happen

Yes, this is expected. This will record CUDA and other host components in sdkm.db file. Have you tried to uninstall after the installation?

I did, and it failed. Here is the log file.

Failed Uninstall (54.4 KB)

Hi dailami,

The log shows that your apt system is broken. When running ‘sudo apt-get check’ command to check your apt system, it reports the following error. The nvidia-cuda-toolkit doesn’t come from JetPack. I don’t know where it comes from, maybe from Ubuntu repository. You need manually fix the apt system error then retry.

802 15:28:07.132 - info: NV_L4T_NVIDIA_NSIGHT_SYSTEMS_HOST_COMP@host: Reading state information…
803 15:28:07.166 - info: NV_L4T_NVIDIA_NSIGHT_SYSTEMS_HOST_COMP@host: You might want to run ‘apt --fix-broken install’ to correct these.
804 15:28:07.166 - info: NV_L4T_NVIDIA_NSIGHT_SYSTEMS_HOST_COMP@host: The following packages have unmet dependencies:
805 15:28:07.217 - info: NV_L4T_NVIDIA_NSIGHT_SYSTEMS_HOST_COMP@host: nvidia-cuda-toolkit : Depends: nvidia-cuda-dev (= 9.1.85-3ubuntu1) but it is not installed
806 15:28:07.219 - error: NV_L4T_NVIDIA_NSIGHT_SYSTEMS_HOST_COMP@host: E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
807 15:28:07.220 - info: Event: NV_L4T_NVIDIA_NSIGHT_SYSTEMS_HOST_COMP@host - error is: E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

Thanks a lot