Jetson 40 pin expansion header configuration

Hello, I am using Jetson nano a02 (4gb) latest version of jetpack is installed.
I want to enable spi pins to connect rfid module to jetson. There is a program called 40 pin extention. It works with file.

When I run it from the terminal, it does not respond. When I run it with uxterminal, it appears for less than half a second and turns off.

# R32 (release), REVISION: 7.4, GCID: 33514132, BOARD: t210ref, EABI: aarch64, DATE: Fri Jun  9 04:25:08 UTC 2023

TNSPEC 3448-200-0000-F.0-1-0-jetson-nano-qspi-sd-mmcblk0p1
COMPATIBLE_SPEC 3448-200-0000--1--jetson-nano-devkit-
TEGRA_OTA_BOOT_DEVICE /dev/mtdblock0
TEGRA_OTA_GPT_DEVICE /dev/mtdblock0

Hi sentrycoder.dev0,

Could you refer to the following steps to use Jetson-IO to configure SPI pins?

1. Run Jetson IO
$ sudo /opt/nvidia/jetson-io/
2. Configure SPI1
Configure Jetson 40pin Header => Configure header pins manually => Select "spi1 (19,21,23,24,26)" => Back -> Save pin changes => Save and reboot to reconfigure pins

Is there any serial console log could be shared at this moment?

The problem is that stays open for half a second with opening the file and closes. If it opens, I will configure the spi pins and the terminal does not give an error

Sorry that I’m not clearly with your issue.
Do you mean the Jetson-IO would close immediately so that you could not configure the SPI pins?
Is there any screen recording could be referred when you hit this issue?

1 Like

I will take a screen recording today and send it to you so you can see the problem more clearly. It’s early morning here because of the time zone difference 😅

1 Like

in the image I directed the problem output to a terminal to a file and shared the output

log.txt (1020 Bytes)

In my second attempt, I got a different output from a log.txt file that I output with the tee command.

Thanks for you screen recording to let us know the status clearly.
We’ve also verified with Jetson Nano A02 devkit, and it seems the Jetson-IO working as expected.

Are you using the Jetson Nano module with eMMC or SD card?

Could you help to use SDKM to flash the board and verify again?

1 Like

I’m using it with SD card I don’t know if there is emmc and I don’t know what you are saying “Could you help to use SDKM to flash the board and verify again?” I’d appreciate it if you could explain more :D I reinstalled Jetpack 4.6.1 it still behaves the same

Please refer to the following instruction to use SDKM to flash the board with latest JP4.6.4 (R32.7.4).
Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation

1 Like

Inside of the jetson nano terminal gives an error for SDK manager and i try download from store but not installed

SDKM should be run on your X86-64 host PC with standalone Ubuntu 18.04 or 20.04 rather than running on your devkit.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.