Jetson AGX Orin not turning on

We have a Jetson AGX Orin developer kit. We were able to set up the machine. However, after trying to upgrade Jetpack with r35.2 (How to Install JetPack :: NVIDIA JetPack Documentation), the machine is not turning on during restart (no screen signal) and is getting very hot.

I ran into the same issue after upgrading to 35.2 from 35.1. I then attempted to re-flash it with sdkmanager but it failed with error [ERROR: failed to read rcm_state. Same error with flash command too. Later I decided to connect UART and console message shows it stucks at booting up to Ubuntu.

1 Like

I just found a work around. I had to re-flash to an external nvme drive (select nvme instead of emmc in the sdkmanager), with that I’m able to boot up r35.2. Still, I don’t know what to do to recover emmc.

1 Like

Same topic as Sdkmanager flash error, can we close this topic?

So we dual-booted Ubuntu 20.04 on a Mac and successfully re-flashed the Orin with sdkmanager. We tried re-flashing with virtual machines on Windows but that didn’t work because of usb connect-disconnect cycles.

Hi david_ye28,

You might need a x86_64 architecture host PC for SDK manager.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.