JETSON AGX XAVIER DEVELOPER KIT does not switch on anymore

Hi All,

I have now used our JETSON AGX XAVIER DEVELOPER KIT for a while, but just brought it into the field where we try to employ it for the direct conservation of an endangered parrot species, the kakapo. As soon as I arrived on the remote island here, the AGX did not switch on anymore, i.e. when switching it on, the light just very briefly plinks one, and then switches off again, instead of staying on as it usually did. I am wondering if this means that the machine is entirely broken (which would be quite a disaster for our project) or if anyone of you has had a similar experience and was able to fix it?

Thank you very much, All!

Best wishes,

Have you checked whether the power source is correct spec?

1 Like

Thanks for your very quick reply @WayneWWW! I indeed wondered if the power system here on the island would be a problem, so I also had a battery be shipped over, and even on the battery it has the same behavior. We do have an AGX with US plug in NZ [], but it did not cause an issues on the mainland. This here is the battery: iForway PowerVault 200 - Portable Power Station

Please let me know if you think this might be a problem; I could ship the AGX off the island to test if it still works on the mainland if that’s indeed an option! Thank you very much.

Do you only have one device on your side now?

If every jetson AGX has same problem, then it might be the power adapter issue.

1 Like

Yes, very unfortunately we only have one device @WayneWWW, and it is so difficult to get another right now… If this might indeed be the problem (despite using a battery as a stable source), I will send the device off island on Wednesday. Thanks heaps!

@WayneWWW, ok, I found a way to test it off the island on Wednesday. May I just ask - if it still doesn’t work - if it might just be broken? I can unfortunately not connect at all since the light switches off so quickly. Tried to connect it to screen and to laptop, but nothing shows up in the short time. I also disassembled it to see if anything is lose, but everything looks alright. Thanks!

If not power adapter issue, then could be broken, and may need to do RMA.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.