Jetson AGX

I have a Jetson AGX Xavier.
I was installing some packages from NVIDIA pipeline server however the memory was full.
When I tried to reboot the Xavier, I couldn’t launch it from the Desktop.
How can I solve this issue?

Hi melissa1,

We have faced the storage problem several times. You can delete the packages which you are not using but it is not useful all the time. The best way is using M.2 SSD disk. After connecting M.2 to your Jetson device, you need to move your root file system on EMMC flash to SSD storage on M.2 slot. We have a blogpost which is “Changing Storage of the Root File System. [EMMC to M.2 SSD]”. You can find it below.

Hope it helps.

Thank you for your reply.
But how can I launch my Jetson AGX to follow these steps? How can I go in recovery mode to try to solve this issue?
I am stuff and my AGX is turned on for a while then it shows me CPU7 shutdown… and I can’t login and see my Xavier Desktop.

Have you tried to use debug port for serial connection?

I am trying.
Do you think it is a memory issue or something else?
Because when I turn on my AGX, I obtain the following error: cp not writing through dangling symlink ‘etc/resolv.conf’

According to this subject, it seems to storage problem.

Another subject about the issue. It might be useful to check them.

I connected the nvidia jetson agx using ssh. Is there a way to run the xavier from root using an ssd card? The link that you provided contains the gui commands.

Actually you do not need the gui for those steps. You can make whole process by using ssh included formatting ssd.

FYI, the earlier dangling sym link message is harmless and won’t have any effect. The shutdown of CPU7 is also harmless. Only CPU0 must operate. Depending on the current energy model (power consumption versus performance can be picked via different models) any non-CPU0 might shut down. CPU0 is a special case and should never be shut down until the system is halted.

If you are on the local network with a Linux PC and this can use ssh to the Jetson, then you can run GUI apps which display onto your local PC by running your PC in a GUI, then using “ssh -X” or “ssh -Y” to the Jetson. This opens a normal ssh console, but redirects any X-server commands to display on the PC itself. For example, if you’ve started ssh -Y from the PC, and then connect to the Jetson, then running command “xcalc” would bring up the GUI calculator on the PC instead of the Jetson (the calculator would run on the Jetson). The limitation is that any requirements for the application’s environment must exist on the host PC, e.g., if it is a Gnome application and requires Gnome libraries, then the host PC must also have the correct Gnome libraries (limited to those libraries used in display). Beware that starting remote applications for local display can take a lot more time, especially for Gnome applications, but gnome-disks should work that way. There are also substitute programs with less overhead.

In the case of a command which is the result of clicking on a menu bar in the Jetson I don’t know what to say. Unless you know how to bring up a command on command line the remote display via “ssh -Y” or “ssh -X” won’t help without knowing the command line.

As mentioned by @ozguryildiz, there are also pure command line substitutes which don’t involve the GUI.

1 Like