Jetson Nano board setup failed during boot

The Jetson Nano Developer Kit starts up, and this is the message during boot:

I am using the Raspberry Pi 2,5A charger:{keyword}&gclid=EAIaIQobChMIjajz9t6q5AIVw8wYCh2RKwJ6EAQYAyABEgLpXvD_BwE

The Nano never succeeds in booting and just restarts every time trying to boot again.

Can anyone help?

Assuming you have the Jetson Nano Developer Kit i suggest to use another SD card with a fresh system image.

Already tried another SD-card, but it was of the same type as the other (same company and 16GB)

You could also try to flash it though sdkmanager.

I got the same issue today after restarting to complete some softwares and Ubuntu updates. I just restarted it using the Reset button on my protective case which is connected to the motherboard to the two reset pins and it worked well. Also, before updating, the Jetson was doing some weird graphical things (icons on desktop were blinking very fast). To finish, I notice that “board setup failed” is still visible and I’m pretty sure it was visible from the very first boot. So, I think it has nothing to do with the issue.