Jetson Nano hanging

Hi all!

I’ve just bought I Jetson Nano last november and I could not get it properly running yet.

It is hanging randomly (it seems). After burning the SD card and starting it for the first time, I can pass through the initial configuration process with no problem. Then, I had the normal system running ok, but, suddenly it hangs. The screen goes black and the board keep its energy light on.

So, I thought it was the system and tried the NVidia Linux system. When system was on everything looked ok, but when I tried to open the terminal, the hanging problem happened again.

Then, I google and read from forums and I looks like it was energy source problem, as I was using microUSB source (but it was not enough for a simple terminal opening?). So, I bought the recommended AdaFruit barel source, burned the microSD with NVidia Linux (forget about Arch) and this time I could open terminal and initiate the system update and upgrade…but (always the but), during upgrade it hanged again. I reboot, tried again, the upgrade finished successfully, I left the board on without using it for several minutes, when I got back it had hanged.

I’m downloading right now the latest version of NVidia Linux and will give another try, but I would appreciate tips, recommendations and info I could provide to help me with this situation.

Thank you very much!

Rafael
I had embbed an Archlinux OS to it so

Hi Rafael,

It sounds abnormal. Better also sharing the the serial log when error happens.

https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

Please also try to give some input to the device through serial console when the system hangs. If you could still get some feedback from serial console, then it means system is still alive, but graphic is somehow dead.

Hi Wayne!

I’m providing my serial cable, but I have good news. I burned with the latest version and my jetson is running properly since yesterday night. Everything seems fine.

The only different thing I did was not create a swap partition: when starting for the first time and asked about the size to extend the partition I used to leave some space for swap partition. I didn’t this time. So…don’t know if was it.

About the possibility of graphic going down I don’t think so, because when it hanged it became unreachable via network.

I think we can close it now.

Now I will try vnc.

Tks again!