Jetson TX2 Network Connectivity Not Working

I have no network connectivity through the hard wire connection. The wifi works as expected. The activity light on my router connected to the TX2 starts activity for a few seconds and stops in a continuous cycle. The interface seemed to work previously before storms.

I connected a USB to Ethernet adapter and experienced the same behavior. I would suspect that if I am seeing the same behavior from a USB to Ethernet adapter and the RJ45 connection that it is not hardware related? I have tried multiple network configurations with static ip, dhcp, etc. to no avail. I have read in the forum that others have had trouble with memory issues causing the driver to crash. Any ideas of how to solve this issue?

[SOLVED]: The TX2 was unable to negotiate the desktop switch it was tied to. Thanks for the replies.
checksum.txt (2.81 KB)
log.txt (68.7 KB)

There’s a lot there I don’t know, but anyone looking at this will want to know the following command output:

sudo -s
head -n 1 /etc/nv_tegra_release
rfkill list

Also be sure “sha1sum -c /etc/nv_tegra_release” shows as ok.

You might attach the output from a freshly booted system’s “dmesg” command. Example: “dmesg > log.txt”. Then on an existing post, if you hover the mouse over the quote mark you will see a paper clip icon show up…you can attach it with the paper clip icon.

If you have a serial console this would give a better boot log since it also shows up during boot loader stage. See: