Jetson TX2 not showing anything. Having a weird sound

Hi,

My jetson tx2 is not powering up. When I turn it on, the light near ALERT! PCIE/SATA goes on for a millisecond and the board makes a continuous sound. There is no HDMI output. I tried connecting through ethernet and sshing in but failed. Can anybody help me figure out this problem? Any help is appreciated.

Can you ping the device? It is quite common for video to not be configured and fail while the system is actually working. The sound does make me think there is a problem (e.g., bad capacitor or power rail). If you have a serial console you will know right away if the system is functional.

NOTE: For ssh and ping I assume you are using wired. WiFi is never a reasonable test except when it works. If you see a DHCP request on a router this is very good as it says the system is alive and might even tell you the router rejected the address instead of the Jetson failing.

I will suggest that you should try ping after attempting to boot with no devices connected, e.g., no USB devices, especially no PCIe devices. Also no monitor. Simplify. With just ethernet you can rule out external devices causing the failure. Should this still fail RMA info is near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/