Latest version of Create 2022.2.1 Physics - Reset Simulation On Stop

This worked in 2022.2.0 version. Now, regardless of the checkbox being checked or not, the simulation resets on stop.

Sometimes I want “fall where they lay” at the end.

I also tried ‘Reset Physics Settings’, and that didn’t change anything.

When I press stop, the spheres line back up even with this unchecked.

I did create the spheres using the array tool for the 1st time, maybe that is what causes it? I will test manually creating and see if that changes things.

I just tried on a single sphere, and the checkbox is now ignored.

To duplicate:

  1. Create new project - add Physics - Ground Plane
  2. Add a sphere (or any prim).
  3. With sphere selected - Add Physics - rigid body with colliders preset
    Run the project with and without the checkbox checked, and when you stop it resets for me whether enabled or disabled.

Hi @DataJuggler! I appreciate the replication steps! I, however, was not able to reproduce the issue on my computer. I also tried using the Array tool, and was not able to reproduce the problem. Could you attach a copy of your usd file so that I can see if the issue happens with your file? You can attach it here or email it to me at omniversecommunity@nvidia-omniverse.atlassian.net

Perhaps me or my computer was tired yesterday. Or the first project I created was corrupted somehow. Today I can’t reproduce this.

I will try on a new project next time before I create an issue. Sorry.

I have the same problem. Box and ground plane, simulation box hit the floor. Oke this works, But reset the box at the start position, I can’t find this. or does not work
. Ton

Hello @t.van.uden! You can find the “Reset Simulation on Stop” option by opening the Preferences menu (Edit > Preferences), then select Physics. You will see the option to “Reset Simulation on Stop” under the General group.

Hi Wendy, Yes I have done that, but it does not go to the start position

I need a little more information on your situation. Am I correct in assuming that you played your simulation with the “Reset Simulation on Stop” option turned off, and are asking for a Reset button to move the objects back to where they were originally?