How to rest Physics to "start positon"?

I have here a bunch of marbles rolling down a table.
How can I reset them back to the “start positon”? By that I mean I had them duplicated in a small group up there above that grey plane, so they could start rolling down…

Pressing stop used to do that, but now it´s not having that effect.

"Train is already gone" kind of feeling heheh!

Hi,
indeed simulation should reset back when you press stop. This behaviour can be disabled through a setting in Edit->Preferences->Physics. Can you please check if you have the setting checked?
See the picture:
image
Regards,
Ales

Hi! Thanks for helping me.
Yes it was ON all the time the way it should be:

What next?

Could you please send me your log file? On the previous screenshot I can see an error related to rigid bodies. Looks like you are nesting rigid bodies. It can misbehave with such a configuration as the writing of transformation will then be order dependent.
To fix that please change the hierarchy so that those marbles are not nested. (not sure it will fix the reset issue but it might, as the transformations applied might not be correct)

Another option you can try is to enable omni.physx.flatcache extension, try to simulate with that extension enabled to see if the reset through this extension works better with your scene. But so far I did not get reports about this not working.

If the hierarchy fix does not work it would be great if you could zip the scene, so that I could try it on my side and debug what is going on.

Thanks!
Regards,
Ales

“change the hierarchy so that those marbles are not nested”
Do you mean so they are not in own scope / Xform folders like this:

I just move them root, all of them?

Sorry to ask again but I always forget where I access the log file :P ?

Pekka

Hello @pekka.varis! You can access your logs at C:\Users\YOURNAME.nvidia-omniverse\logs

Oh sorry I missed the reply.
Nested rigid bodies error is issued when you have a hierarchy of rigid bodies like:
– rigid body
---- rigid body

Then the simulation that outputs world transformations can write in incorrect order as it needs to write local transformations back to USD.

In theory it should still work, but its worth to fix it first as the simulation results might not be correct.

Otherwise, please send me the log file or the usd file, so that I can take a look what the issue can be, since I have no other reports yet that this would be broken.

Regards,
Ales