Nano module on nano 2GB kit, USB does not works

I have Jetson Nano Module and Jetson Nano 2GB dev kit.
My Nano 2GB dev kit works well with Microsd card.
Because I want to use Nano as emmc, I removed 2GB dev kit’s bundle module and put Jetson Nano Module with emmc.
But during I flashing Nano Module by SDK Manager, and the manager showed that I have to do some account things, I found Jetson’s USB devices-Keyboard and mouse- does not worked.

I pluged Keyboard and moues’s USB to Carrier board and flashed OS several times but still they are did not work. Keyboard and moues just shows no signal like no light on the bottom of the mouse.

So I stopped in this step.

I think my Keyboard and mouse, 2GB dev kit’s carrier board, USB-C power supply has no problem because they are works well with 2GB dev kit’s bundle module.
Is there any way to recover USB ports? Or Jetson Nano module does not compatible to 2GB dev kit’s carrier board?

Because English is not my first language, I’m sorry for my English skill.

Hi koseungcheol,

We will check this issue internal and update.

What JetPack version are you using?
Could you also provide the uart logs?

I tried JP 4.5 3 times as Nano module, Nano dev kit, Nano dev kit 2gb.
Also tried JP 4.4.1 as Nano module.

So the software release is not the cause here, right?

I think so.
But if you need, I will try older JP version.

Is there any progress…?


This usecase is not supported because the device tree is not compatible. You cannot use 4gb module on 2gb carrier.

Then, using Jetson Nano module(with emmc) on xavier NX or Xavier NX module on Nano carrier board also does not supported?

Please refer to Considerations when using Jetson Xavier NX module with Nano devkit carrier