Network settings crash on open

I recently purchased a Jetson Nano production board. It came with 16Gb of eMMC.

I am new to both Jetson Nanao and Unbuntu.

When I try to open the network settings page to allow for sharing (setting up RDT), it seems to crash and will not open. The first time it I tried, the screen turned grey as if it was trying to open, then it just went back to the main settings page. The second time I tried, it just failed without turning grey.

Should I try to fix the current setup, and if so, how can I repair Unbuntu?

If it is <easer/better/new jetpack> to flash the new JetPack on to the eMMC, how would I go about this?

Thank you

Hi Beengie,
Does your board is NV devkit? if so, you can flash Nano via sdkmanager

Thank you for the link.

I have been there and wish to use that solution. However, I am confused since it looks like I would have to have a host Linux computer to connect to the Jetson Nano. Currently I do not have a Linux system other than the Nano.

Am I able to flash Linux on a microSD and then run the SDK Manager to flash the eMMC?

Hi Beengie,
if you wish to flash on emmc, host is must choine to flash

Just to clarify something, a dev kit from NVIDIA is an SD card module plus a carrier board. These do not have eMMC. There are eMMC modules, but they are not part of dev kits. Some of them have SD card slots, but those are on the carrier board, and not on the module. The software supporting them differs quite a bit, and the eMMC models do not boot from the SD card. So:

  • Dev kits flash the o/s to the SD card.
  • eMMC models flash the o/s to the eMMC.
  • SD card models put boot content on QSPI memory (part of the module, not the carrier board).
  • eMMC models flash the boot content to partitions on the eMMC.
  • Drivers present in boot will differ between the two models.
  • Regardless of model the boot content has to be compatible in release to the o/s partition. This implies that some SD card rootfs partitions won’t boot if the release is not compatible with the QSPI memory content.
  • SD card models flash the QSPI separately from the SD card.
  • eMMC models flash all to the eMMC.
  • It takes a Linux host PC (you’d want Ubuntu 18.04) to flash QSPI even if the SD card can be flashed separately with Etcher. This works if and only if the QSPI already has content valid for that SD card release. You must use the Ubuntu host to flash the QSPI content of the SD card model. You must use the Ubuntu host to flash the eMMC content of the eMMC models.
  • Because of differences in carrier board layout one must get the flash software from the manufacturer if the carrier board is not the dev kit (there are exceptions for the rare case when electrical layout of the carrier board is a match to the dev kit carrier board).

JetPack/SDK Manager is a front end to the actual flash software. “Linux for Tegra” (“L4T”) is what gets flashed, and is basically Ubuntu plus NVIDIA drivers. JetPack/SDKM and L4T releases are tied together. You can find instructions for dev kits at a given release here:

If you have third party carrier board, then you should check their software (the board support package).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.