OmniGraphError: could not create node using invalid type 'omni.replicator.core.Ognwriter'

When running the example code found here, I’m getting the following error: OmniGraphError: could not create node using invalid type 'omni.replicator.core.Ognwriter'
This happens in both Omniverse Isaac and Omniverse Code.

Hi Lukas, I tried the example using Isaac Sim 2022.1.1 and it worked fine for me. Could you let us know what version were you using and which operating system? If you still get the error could you also upload a log file? Thanks!

I am facing the same issue. When trying the same in the latest version of Isaac Sim (2022.1.1), I get the error while importing the library itself. omni.replicator.core not found. But omni.replicator imports fine.

Would it be possible to share the script to replicate this?

There is no script. I am just executing a single line import omni.replicator.core which throws me ModuleNotFound error. However, the exact same line is executing in Ominverse Code

Are you executing the code in the Script Editor?

Yes. From Window > Script Editor

It seems your Replicator extension is not enabled, can you try enabling: Windows → Extensions → OMNI REPLICATOR

It is enabled. However, there is some issue with it. Please find the logs for both omni.replicator.core and omni.replicator.composer

omni_replicator_composer.log (3.1 KB)
omni_replicator_core.log (3.1 KB)

It seems for some reasons your extensions are not loading, before I sent this to the dev team is it possible for you to do a clean install?

Did fresh installation as you suggested. The issue still persists.

There is a dependent extension that is not loading properly, can you provide the full log file?
The path to this is printed in the terminal window at the start.

Update: I am not able to load ROS bridge extension as well. Please find the attached logs in this reply. I have added logs starting from when Isaac Sim is launched all the way to loading the extensions

Edit: The issue is resolved. The Nvidia drivers which are installed is 510.60.02 and there was a script in /etc/profile.d which was pointing to Cuda drivers 11.7 instead of 11.6 so it was not able to find proper Cuda libraries.

Sorry for the inconvenience caused and thanks for all the help.
isaac_sim.log (59.7 KB)

It looks like the cuda installation is somehow broken and it cannot find libcuda.so , can you run:
ldconfig -p |grep libcuda

There should be an entry that is just libcuda.so there

If not you can re-install the driver, or manually create the symlink using the example steps below, they might not exactly match your directory structure:

cd /usr/lib/x86_64-linux-gnu/
sudo ln -s libcuda.so.1 libcuda.so
sudo ldconfig

and then

ldconfig -p |grep libcuda

to confirm that libcuda.so is found by the system.