Problem with PTP in a Port Channel on Mellanox SN2010/SN2100 Switches

We use 1 Mellanox SN2010 and 1 Mellanox SN2100 Switch (with Onyx X86_64 3.9.3220) and have them connected to each other with 2 100G Fiber Links.
Both switches are used in a enclosed broadcast environment with different VLANs (for Management, for SMPTE2110 Media streams etc.) and PTP on the Media VLAN (PTP generated by a sync generator connected to the SN2100). Now we wanted to create a port channel with both links between the switches. The physical interfaces as well as the port channel are configured as switchport mode trunk and all the vlans allowed.
We don’t use special IP routing on the network. LACP is enabled.

The problem is, that once the port channel is activated (the physical interfaces are added to the port channel interface with “channel-group 1 mode active”), PTP doesn’t get through the port channel, and so our media network doesn’t work anymore (because the GM can’t be found by the other switch). Once the physical IF isn’t added to the port-channel anymore, PTP clocks right to the correct GM and everything is working again.

It’s also weird, that the running-config shows, that ptp is enabled on the physical IFs as well as on the port channel, but the command " show ptp interface port-channel 1" replies, that there is no ptp enabled on the port-channel.

Does anyone know, what the problem might be in our case?
LMK if more detailed information is needed.

Greetings from Germany,

Hey Florian,
This sounds like an order of operations issue with enabling PTP on a port-channel. Documented in issue 2306061.

Can you blank out the interface config, add interface to port-channel and then enable PTP?


1 Like

If this does not solve the issue I suggest upgrading to the latest code as there are quite a few fixes for PTP.

Lastly if you still need help after these suggestions this is probably best suited for a support ticket to get a deeper level of analysis on it.

Hi Charles,

I am a colleague of Florian. He is on vacation at the moment and that’s why I am reporting here.
Thank you very much for your solution suggestion. We will try this and give a short feedback with the result.

With best regards

1 Like

Hi Charles,
We reconfigured the port-channel and enabled the ptp after configuring the port-channel on the interfaces. You were right and everything is working perfectly!
Thank you for your answer and your knowledge!

Greetings from Germany

1 Like

Hello Florian,

Great news. I am glad to hear things are working.