Question about stacking

We just got two SX1012 swtiches for use with a SCALE cluster.

We received a stacking cable with the pair, which I have plugged into port 10 on both switches.

When I asked Scale, they said that plugging in the cable is all that I would have to do to tie the switches together?

This didn’t seem to make sense to me,and in any case, doing that did not allow me to hit both switches if only one of them has the mgmt interface plugged in.

So I looked around and saw that I think I needed to setup a MLAG, so I found some directions and did that.

now both switches are setup that way, but I am still missing some piece.

If I do a show mlag from switch one, it says that is active-full, it is the master, but operationally down.

If I do a show mlag on switch two, it says that it is active-full, it is the standby, but operationally down, however it also says mlag members summary and lists itself, switch one does not have this.

So something on switch one, i am thinking is not enabled, but if I go through the config line by line, they appear to have the same settings for all ports, port-channels … etc.

The plan is to do the following.

connect both switches to each other via stacking cable, and they connect to 3 Scale nodes with one connection from each switch going to Backplane and Lan ports on the Scale nodes.

I want to then use ports 11 and 12 on the Mellanox to port-channel over to my 2 cisco switches, so that each Mellanox has 10 GB to each of my Cisco’s LACP for 20 Gb from network core to the Mellanox switches.

What am I missing to make these connections? I want to ensure that if either of my Mellanox or either of my Cisco fail, that users will still be able to reach the VMs on the Scale cluster.

Any help would be appreciated, if you need to see the mellanox configs, please let me know.


Hi Craig,

The SX1012 switches don’t support Stacking, it does support MLAG, can you try reviewing the below article (if you haven’t reviewed it already).

How To Configure MLAG on Mellanox Switches

Also - after doing that - please paste the configurations of both switches here and indicate each port and it’s what it’s connected to.

Well i have it configured to talk over the port that the stacking cable is connected into, but if you are saying that it can’t use a stacking cable, that is probably my issue. I will further investigate.