Reboots by itself over and over

After booting it up and going through the Ubuntu setup prompts - about a minute or two after this… It reboots over and over just after getting to the desktop.

I have rebuilt it 3 times now - flashed the sd card each time using the image provided in the Getting Started guide.

And i tried a different sd this last time…

I’m using the recommended power specification - a 5V 4amp switching power supply
I also tried to cap the power consumption with sudo nvpmodel -m1
I’ve tried unplugged the mouse and keyboard and ethernet.
None of these thing works.

It gets to the ubuntu desktop for about 30 seconds before it reboots…

Have you changed any kernel setting or install anything on the devices? Is it nvidia devkit?

Are you able to see any special kernel error during the 30 seconds you have?

Could you dump below node after your reboot?
https://devtalk.nvidia.com/default/topic/1042139/jetson-tx2/jetson-tx2-reset-powerdown-issue/

This is a devkit I picked up at GTC. The sd image is from your getting started page and is dated April 19th.

When I set it up the first time I plugged in a camera, but it didn’t boot. So I unplugged it and it booted. Then it rebooted midway through boot, so I got a better power supply. It booted up all the way, and I was in the middle of installing numpy when it froze. It wouldn’t boot after that. I checked the SD card and it was fried.

I bought a new card and a new power supply.

I was able to setup the first computer vision demo from jetpack. Then I tried setting up mxnet. The build was taking well over an hour on Friday, so I just left it. I came back Monday to the nano being “off”. After waking it up by wiggling the mouse and tapping the keyboard, it booted up and gave me the desktop and I was able to open terminal. I tested Python and to see if MXNet was working. It was not. So maybe it crashed mid-build. It stayed alive for about 2 minutes total, then rebooted. A lot. I flashed it again (this is a 128GB card). It rebooted after going through the setup process (new account, keyboard setting etc.) I didn’t even get to clone a repo. I switched to a 16gb card, flashed it and the same thing happened.

At one point I did some some “ubuntu recovered from a serious error” message, but it didn’t let me investigate before it rebooted.

I don’t know what you’re asking for with “dump below node after your reboot”…

I had similar issues but resolved them. I was trying to use an old raspberry pi power supply, and it would mostly work until I stressed the system, at which point it would reboot. I couldn’t find any micro-usb power supplies that would survive a stress test. A new 5v, 4a, barrel jack power supply resolved the issue. It’s very stable now. I haven’t had a reboot since. Don’t forget to jump j48 to switch the power input off from micro-usb and gain a usb2 port.

The new power supply I’m using is the 5v barrel one and the jumper is jumped.
It worked for a time… Enough to build a couple of projects but it’s totally unstable now.

How are you flashing the cards?

BalenaEtcher

That’s exactly what I used. I was thinking you may have used dd and a crummy reader without a verification pass or something. So assuming your cards are good, that still sounds a lot like the power supply to me. Do you have a second one on hand, perhaps from a different brand, to rule that out?

This is what I bought

5V 4A (4000mA) switching power… https://www.amazon.com/dp/B01LY5TG5Y?ref=ppx_pop_mob_ap_share

The one that was linked from one of the docs was sold out, but this matched the specs and people were buying it and an SD card, so I went with the recommendation of the hive mind.

I got this one. It was “Amazon’s Choice” for “5v 4a power supply”. You could get one or another from AdaFruit and see if that resolves it. If after all that you’re still having problems, I’m all out of suggestions and I’d be inclined to point at the Nano as the culprit.

I’d really like to test my PR for getting Nano and TX builds working with MXNet, but I’m blocked by this hardware(?) failure. I guess I can order the other adapter today and wait and see. However, I’d really like to know if there’s a good way to diagnose the power issue without buying more adapters on Amazon. Seems wasteful and I’m more inclined to RMA the Nano since it fried an SD card already, rather than replace a brand new power adapter that seems ok and matches specs.

It’s frustrating when a bunch of things could be the problem and you can’t pinpoint it. Still, it’s probably easier to rule things out that you can before an RMA that might take longer.

Hi aaron.s.markham,

This is weird that this device can even break down your sdcard. Please file a RMA to us and we will investigate it.

I am really sorry for inconvenience.

Hi aaron.s.markham, before RMA, please provide the serial number of board so that we don’t loose track of this unit.

Hi all,

Same problem here. I received my nano three days ago. I flashed the microSD, updated operative system, and nano rebooted itself twice while testing the media player (I was watching a film and the nano rebooted twice). then I tested with a new microSD (also 32 Gbytes), flashing via linux command line (dd) and everything works fine but it keeps on rebooting. If I connect the hard disk it makes a weird noise (the same noise as when it was connected to raspberry pi with an incorrect power supply. I guess it has to do with that. By now, without the hard disk connected, it has not rebooted yet (probably because it has enough power to work).

It’s weird because I bought the recommended power supply for nano. Any hint? Should I buy a new power supply (with the one of my mobile phone it crashes even before)? It’s a problem with my nano and should I ask for a new one?

Thanks in advance!

Hi elalfredini,

Please send board RMA, and please provide the serial number so that we don’t loose track of this unit.

Thanks so much for your reply. I’m sending you an email with that information. I’m sure that it has to do with the power supply. I’m using 5V/3A and I guess I would need, as I read, 5V/4A, because I’m connecting a hard disk, a mouse, a keyboard… I’ll buy a new power supply and I will let you know.

Yes, please try 5V/4A power supply as request.

This one didn’t work:
https://www.amazon.com/gp/product/B01LY5TG5Y/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1

This one did work:
https://www.amazon.com/gp/product/B01N4HYWAM/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

Now with this other power supply the nano doesn’t reboot on its own!

Just pointing out that both of these power supplies are 5V/4A, so even matching the specs, you can still have issues.