ROS driver for quad GMSL camera on Drive Agx platform

Please provide the following info:
Hardware Platform: [DRIVE AGX Xavier™ Developer Kit]
Software Version: [DRIVE Software 10]
Host Machine Version: [ native Ubuntu 18.04]
SDK Manager Version: [1.0.1.5538]
Hi Everyone,
I want to run GMSL camera with ROS , when I want to compile some ROS driver for it the it ask about #include <dw/image/FormatConverter.h>
and in driveworks folder there is no any formatconverter
can you help me about this probmel.
I am using Autoware.ai 1.13

Per below path of DRIVE Software 8.0 documentation, the file is in DrvieWorks 1.5. So the ROS package you try to build is still based on the old release.

<NVIDIA_DRIVE_SW_8.0_References>/DRIVE_Software/DRIVE%20AV/baggage/FormatConverter_8h.html

I’m not sure which package you are using but in below topic a developer successfully upgraded the ROS package to DRIVE Software 10.0 (DriveWorks 2.2). FYI.

Hi,
Thanks for your help.
I have a problem for building this package because I want to compile I got this error
autoware_driveworks_interface won’t be built, CUDA and aarch64 are required.
Can I install cuda 10.0 on my drive ?
It has cida 10.2 but the autoware need cuda 10.0

You may be able to consult the developer in the topic I pointed out. I guess he ported the package to CUDA 10.2 (DRIVE Software 10.0).

Hello, here you can find the version I ported from autoware’s version: https://gitlab.com/leo-engineering/Drivers/sekonix_camera

Dear Ftih.cirit,
Thank you very much for your help. I compiled the driver successfully on the Drive . But I have a problem with my GMSL cameras.
with this command I show my camers:
./sample_camera_multiple_gmsl --type-a=ar0231-rccb-bae-sf3325 --selector-mask=1111
but when I use the launch file I dont have images.


could you please help me to this issues.
this is the launch file

Best Regards

Are you sure there are no images?
Images are being published in compressed format.

Can you show us the
rosnode info /sekonix_camera_node
result?
and for the published topics,
try
rostopic hz /port_3/camera_1/image_raw/compressed

since you have plugged 4 cameras to fourth port.

EDIT second command is rostopic

Hi

sorry second command should be

rostopic hz /port_3/camera_1/image_raw/compressed

instead of rosnode

I connected 4 camera to the port 0

See, your images are being published with 30 hz :)

Try
rqt_image_view /port_0/camera_1/image_raw/compressed

or just open it with rviz but dont forget to select compressed

Thanks so much Dear Fatih.
I have all images in compressed format.
Thanks for your Helpful information

You’re welcome, good luck with your project!

just one question , where can I change the parameters for the camera , like resolution , size, FPS and …

You need to use opencv functions to resize it in the place where it is being published. For FPS change, you need to regulate it yourself to reduce the FPS, for that you need to analyze the code yourself, feel free to fork.

Thanks Dear Fatih