Running isaac sim on cloud (Tesla T4 GPU) - No physical device is found

I have a machine with Tesla T4 GPU on cloud (huawei cloud).

I have setup ubuntu18 (with desktop - gui) which I access it through teamviewer.
However, I was getting following error msgs

Can anyone help me with how to bypass this issue?
Thanks

Hi, please provide more information about your setup. Which drivers are you using? Are you running Isaac Sim natively?
Try running nvidia-smi.

yes, I am getting the error when I run it natively
_build/linux-x86_64/release/isaac-sim.sh

I have a machine with 460.39 driver installed.
but on that machine, things run fine (this one has a display though)

You might need to check if you have TeamView setup correctly. A display (physical or virtual) needs to be connected to the GPU to run Isaac Sim natively. Try running with the --no-window flag and see if it works.
Here’s some useful info: Linux Troubleshooting — Omniverse Nucleus documentation

--no-window does not change the situation unfortunately.

what do you mean by A display (physical or virtual) needs to be connected to the GPU to run Isaac Sim natively?

Sounds like installing nvidia-driver is not sufficient? can you describe a little bit about how it should be setup and what I need to / how I can check?

See Q6 and Q7 at Linux Troubleshooting — Omniverse Nucleus documentation
A display is needed to run windowed Isaac Sim natively. Try running echo $DISPLAY to test.
Does running headless work?

_build/linux-x86_64/release/isaac-sim.headless.sh

./_build/linux-x86_64/release/isaac-sim-headless.sh fails with the same error msg. No Physical device.

echo $DISPLAY currently gives me :1

Looks like the display is ok. Can you try reinstall the drivers? I recommend installing version 460.73.01 using the .run installer.
https://www.nvidia.com/Download/driverResults.aspx/173142/en-us

so, I did bit more googling, and trying various options to overcome this issue.

I think I have something promising now and this is what I did.

From the link you shared, I have noticed that X11 config must be used to link display with the gpu

I tried generating a fresh config using nvidia-xconfig but it wasn’t working.

I continue googling and found that if X11 server was running before I install the driver, it can affect nvidia-xconfig from generating the correct config.

So I uninstalled driver, removed the existing X11 config, disabled gdm (lightdm) and reinstalled the driver and re-ran nvidia-xconfig

After that I found that the headless mode is working.

I still have a couple of questions which I hope you can answer.

  1. Is there a way to check if my Display/GPU (X11) is configured correctly without running the simulator?

  2. is it possible to run non-headless mode on the machine without display somehow through teamviewer?
    I am currently seeing

I really appreciate your help!

1 Like

So I uninstalled driver, removed the existing X11 config, disabled gdm (lightdm) and reinstalled the driver and re-ran nvidia-xconfig

Cool. Yes. This should help fix the issue. Just checking, did you installed the Tesla T4 specific drivers using .run command?

You should also verify if Vulkan is working. See Q3: Linux Troubleshooting — Omniverse Nucleus documentation

If you installed the Vulkan SDK, you can run “vkcube” to test run a Vulkan application. https://vulkan.lunarg.com/doc/view/1.1.126.0/linux/getting_started.html

Other than that, I think you should check the compatibility of streaming Vulkan applications with TeamViewer.