Running Marbles RTX on a 4090?

I just got a 4090 and I was looking forward to making it sweat with the Marbles RTX omniverse app. However, I’m running into multiple issues.

First, anytime I open Omniverse at all, I get a popup error stating “Failed to execute script main”, and then whenever I start Marbles RTX, the Launch button loads a bit, and then nothing happens.

When trying to directly open the kit.exe, I get the following error:

[Info] [carb] Logging to file: C:/Users/me/.nvidia-omniverse/logs/Kit/
[Info] [carb] Initializing plugin: (interfaces: [carb::events::IEvents v0.2]) (impl:
[0.091s] Loading user config located at: ‘C:/Users/me/AppData/Local/ov/data/Kit/’
Fatal Python error: initfsencoding: unable to load the file system codec
ModuleNotFoundError: No module named ‘encodings’

Which is weird, because I do have Python 3.11 installed and it’s also added to PATH (I’m using Windows 11), and I can run Python and import “encodings” from the command line.

What am I missing here? The PC is a relatively new build running an RTX 4090 paired with a 12700K and 32 GBs of DDR5.

Thank you!

Hi @valaki0525, I think you will get better feedback if you ask directly on the Omniverse forums.

I moved your post over there for convenience.


1 Like

Hi @valaki0525. Did you try launching the app from the launcher?

Kit apps currently use Python 3.7. If you launch an app from the launcher or using the batch files like omni.create.bat, then it should use the Python install that we ship with. You could try removing your python from the PATH, but I don’t think you should need to do that.

Hi @mati-nvidia
Thanks for the reply. I tried launching directly from Omniverse at first, then the .bat marked as “entrypoint” in one of the toml files, and finally the kit.exe. All three resulted in the error message.

I just tried Marbles RTX and it works for me. Also, the Python in PATH should not be affecting Kit. Can you share your log files so we can take a closer look? How to Report an issue with Omniverse

Also, worth checking to see if any other Omniverse apps from the Launcher are working for you.

kit_20230316_102222.log (5.2 KB)

Attaching my last log. I’ll try another app and let you know!

After uploading my log, I’ve tried downloading View from the Omniverse app, and that works just fine. Seems I have a specific issue with Marbles RTX and its Python installation, huh.

Hi @valaki0525. Still looking into this for you. If you try removing your system python from PATH and removing PYTHONHOME if you have it set, that could help narrow this down in the mean time.

Hi @valaki0525. Marbles RTX may be moving into our Showroom app and that’s part of the reason why it hasn’t gotten an update recently. We’re tracking this work internally though with this ticket number: OM-88179.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.