SDK Manager Jetpack 4.6 DevZone get download url failed


I have been trying desperately to download JetPack 4.6 on my work computer via SDKManager 1.6 and keep running into issues with downloading all of the components.

Every time I start the download the SDKManager starts downloading the .deb files but returns this error -

ERROR: CUDA on Host - host: DevZone get download url failed: TimeoutError: Timeout awaiting ‘request’ for 60000ms.

I am behind a proxy at work and my machines environment, apt, and wget are all set to the same proxy settings.

I tried downloading the .deb files in my Firefox browser and had no issues, however if I tried using wget I received a 403 error. I’m assuming this is because the download requires some form of validation from my Nvidia Developer account.

My host machine is running Ubuntu 18.04.5 LTS x86_64

I tried following these posts with no success

Hello aledet,

Have you set proxy settings in SDK Manager per SDK Manager Settings :: NVIDIA SDK Manager Documentation?
If you have set the settings correctly and still have the issue, could you please package ~/.nvsdkm directory and attach it to the thread for more investigation?

Hi EdwardZhou,

My proxy settings are set in the SDK Manager as described in the documentation.
Attached is my nvsdkm directory.

Thank you (568.1 KB)

Hi aledet,

We found that it is caused by a regression of SDK Manager client when handling proxy. As a workaround, can you please download all the files on a machine with direct internet access first (without using any proxy), then install with SDK Manager? We’ll fix the bug later.

1 Like

Hi aledet,

We’ve fixed the proxy issue in latest SDK Manager 1.6.1 client. It is available at .