Sdkmanager exits immediately after launch


I am trying to use sdkmanager (and jetpack) to bring up my AGX Xavier.

I installed sdkmanager_1.2.0-6733_amd64 on the host PC then tried to launch it using

the command ‘sdkmanager’.

However, it exits without any messages or errors right after I run it.

Does anyone has seen this issue? How should I solve this?

Hi gliese581gg,
Can you please provide the ~/.nvsdkm/sdkm.log file in attachment?

Thank you for quick response!

here is the log :


2020-07-08 17:12:25.179 - info: Current DB Version: 12
2020-07-08 17:12:25.333 - info: forking worker process
2020-07-08 17:12:25.339 - info: initializing the download service
2020-07-08 17:12:25.345 - info: forking a child process for the download service pid 73977
2020-07-08 17:12:25.349 - info: Initializing download manager with 6
2020-07-08 17:12:25.419 - info: SDK Manager log file name: sdkm-2020-07-08-17-12-24.log
2020-07-08 17:12:25.423 - info: closing command line window with error:
Error: unknown argument ‘–sandbox’
2020-07-08 17:12:25.423 - error: command line execute failed with error:
Error: unknown argument ‘–sandbox’
2020-07-08 17:12:25.424 - info: cleaning up engine
2020-07-08 17:12:25.424 - info: installManager cleanup
2020-07-08 17:12:25.424 - info: cleanning up the downloader and worker
2020-07-08 17:12:25.424 - info: [Worker] destroying
2020-07-08 17:12:25.425 - info: The overall duration (Download + Install) is 0.063s

2020-07-08 17:12:25.426 - info:
*** Download Summary ***

    - Bundle:
    - Download server:
    - 0B downloaded of 0
    - Download started on: .
    - Download ended on: Wed Jul 08 2020 17:12:25 GMT+0900 (Korean Standard Time).
    - Download duration: 0.063s.
    - Average total download speed: 0B/s = total downloaded bytes / download duration.
    - Average total bandwidth: 0B/s, average accumulation of all file chunk's speed, downloaded concurrently.
    - Average file chunk's download speed: 0B/s, average of all downloaded file chunk's speed.
    - Max 6 concurrent files using 6 threads.

    Total 0 files:
    - 0 downloaded, 0 cached, 0 failed, 0 skipped

                                                                                                           1,1           Top


From above log, it seems that SDK Manager was called with an unknown argument ‘-sandbox’. Can you please confirm which exact command was called? If it is called with exactly ‘sdkmanager’, is there any alias in bash settings that appended this command with other arguments?

It turned out that writing to ‘~/.nvsdkm’ required sudo authentication because I probably used sudo when I ran sdkmanager for the first time. The issue is solved after I changed the permission mode of ‘~/.nvsdkm’ to 777