[SOLVED] TX2 4GB does not boot on custom board, while TX1 works fine

Hi, since TX1 is going to the end of life, we are trying to replace it with TX2 4GB module, but we have serious problems running it on our board.
After bringing the POWER_BTN signal down for a second, the module powers on (CARRIER_PWR_ON goes high), but the module doesn’t boot. Ethernet doesn’t link, there is no USB device appearing in the connected system, there is no output on UART0_TX (although the logic level goes high). I tried both recovery and normal boot, but neither seems to be working.

Our board is based on B04 carrier board. We have produced many of them, and many TX1 modules were working fine on it. TX2 doesn’t. We have bought C02 carrier board from NVidia, and the TX2 4GB module we have boots and flashes fine on it, so the module is fine.

I have captured the power signals according to Table 5. Power & System Pin Descriptions in the TX2 OEM Design Guide, and they are identical between the C02 board and our custom board.

I have also checked the strapping pin signals. As far as I understand, the only pins that may cause such behaviour are UART0_RTS (G11) and UART1_TX (D9). G11 is not connected on our board, and D9 is connected to one-way level shifter, so it cannot be pulled in any way. I have captured analog signals on D9, and also on the SLEEP (E2) pin, and they all seem to be fine.

Can you tell me what pins else may prevent TX2 4GB from booting and entering recovery mode, while they don’t affect TX1?

I found out that the JTAG_GP1 was pulled to 1,8V. Removing the pullup resistor solved the problem.