Specifying usb instance to connect to with flash.sh

On an Ubuntu system, it is unclear to me how to utilize the --usb-instance flag in flash.sh. I have tried adding various things from lsusb output with no success. Can you provide an example of using the --usb-instance flag on an Ubuntu system?

Hi @mooch1,

Sure, first of all if you need to use the flash.sh script to flash a Jetson device you have to make sure you are setting the Jetson in recovery mode, that will depend on which Jetson platform you are using.
After set the recovery mode and connect the Jetson to your pc through USB you could check with lsusb and you should have and output with something like this:

Bus 001 Device 010: ID 0955:7f21 NVidia Corp.

So there you can see there is a Jetson device (NVidia Corp.), actually there is no necessary to use the --usb-instance flag, since your system will detect when the board is connected, however here you have an example on how to use the flag, using the Bus 001 Device 010, the following command worked for me:

sudo ./flash.sh --usb-instance=/dev/bus/usb/001/010 jetson-nano-devkit mmcblk0p1

This is for a Jetson Nano devkit, but how I said you should be able to run also:

sudo ./flash.sh jetson-nano-devkit mmcblk0p1

Without any issue, because your system will detect the Jetson connected. Here you have a guide about Flashing and Booting the Target device.

Hope this helps!

Greivin Brenes
Embedded SW Engineer at RidgeRun

Contact us: support@ridgerun.com
Developers wiki: https://developer.ridgerun.com/
Website: www.ridgerun.com

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.