Trouble in saving map when i follow Tutorial for Visual SLAM with Isaac Sim

I ran the command that 'ros2 action send_goal /visual_slam/save_map isaac_ros_visual_slam_interfaces/action/SaveMap “{map_url: /home/gaozhao/map}” '.In the terminal,it showed’success: true.However,i could not see the expected map in the target directory ‘home/gaozhao’ or in ‘home/gaozhao/map’.Except for this,anything else seems to go well!
HELP!!!What is the problem?

Hi @gaozhao22 - The issue you’re experiencing might be due to a few reasons. Here are some things you can check:

  1. Permissions: Make sure that the process running the ROS2 command has the necessary permissions to write to the target directory.
  2. Path: Ensure that the path you’re providing is correct. In your command, you’re providing an absolute path (/home/gaozhao/map). If the path is incorrect or does not exist, the map file might not be saved correctly.
  3. ROS2 Action: The ros2 action send_goal command sends a goal to a ROS2 action server. Make sure that the action server for /visual_slam/save_map is running and is implemented correctly. You can check the ROS2 action server’s logs for any errors or warnings.
  4. Map Saving Process: The process of saving the map might take some time, especially if the map is large. Make sure that you’re allowing enough time for the map to be saved before checking the directory.

If you’ve checked all of these and you’re still not seeing the map file, there might be an issue with the way the map is being saved. You might need to debug the map saving process in the /visual_slam/save_map action server to see why the map file is not being created.