TX2 Can't enter recovery mode or work with Serial Console

First issue was the cr1 and ‘alert pcie/sata powered up’ buttons flashing once and then turning off when I attempted to power up the TX2. This persisted for some time before all lights on the board came and stayed on, but still nothing to the monitor. When I try to enter recovery mode and re-flash it is never listed as “Nvidia Corp” when I run lsusb after putting it into recovery mode.

I set up a serial console and plugged it into my desktop but I cannot get access to a terminal.

I tried all of the above with a different TX2 module on the same board, and as expected it all works.

Is there anything I can do to reset the currently not working TX2 module to factory settings? What information might I be missing about debugging this issue?

If the same power supply is used with different modules on the same carrier, but only the one module has indicator lights which differ, then it is probably a hardware issue. On the other hand, if the host sees the Jetson via lsusb when in recovery mode, then there is a chance it is just some software. If you can’t reach recovery mode, then it is in need of RMA.

One test of basic function in recovery mode is to see if it allows an attempt to clone. See:
https://devtalk.nvidia.com/default/topic/1000105/jetson-tx2/tx2-cloning/
(keep in mind that cloning depends somewhat on release…mostly the release of the driver package and not what was originally on the Jetson)

See what shows up as pass or fail from a log of cloning. Here is an example clone command with logging:

sudo ./flash.sh -r -k APP -G my_backup.img jetson-tx2 mmcblk0p1 <b>2>&1 | tee clone_log.txt</b>

Do make sure you have a lot of spare disk space where you run the command from if you want to do a complete clone. On the other hand, if you are just testing, then you could see if it begins actual disk copy and run in for two or three minutes and then interrupt it.

You could skip a clone test and just try to flash, but more things have to succeed for flash versus clone to succeed.

I tried again and unfortunately I am still unable to put it into recovery mode - the host doesn’t see Jetson via lsusb. What exactly is the process of Returning a module?

Go to this URL and search for “RMA” near the top:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/