URDF Import NAN error

Hi all,
The joint states of my robot imported show NAN values in all records as below.

What can be the possible causes for it?

I’ve tried my old works, it turns out to display the SMAE error now.
It could be a wrong setting possibly, while I don’t remember having done…
Where is the settings about it?
Thk u.

BTW, the situation is the robot hanging in the air with or without gravity and its NAN values of joints all the time.

When I rebuild a scene with the old URDF file, the old scene worked correctly does not work now.
After checking the elements under the Stage, it turns to be a USD file rewriting problem, tuhs the old relying USD file destroyed.
I reassigned the output directory and it does not work still.
What can I do now ?

I changed the IS Launcher to 2022.2.1, the gravity issue disappeared.
does it have anything to do with the newly release vesion?

URDF Importer cannot detect the Floating joint type.
I added it manually , named D6 though.
Finally I solved it with so many efforts.
Save the post as a recording for myself.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.