Using SDK Manager to Install TX2 Get Error

Hi,

I using SDK Manager to update tx2 , when finished setting(set keyboard , time zone , username) ,my TX2 login into the system, I can see the Desktop, and then I type the username and password, press Install, the SDK Manager shows TX2 in recovery mode, so I reboot the TX2 , after that I try to type again to press install , but SDK Manager shows Incorrect username or password.

Incorrect username or password

Hi vis51230,

Are you using TX2 username and password to login SDK Manager’s post-flash installation dialog?
Please enter the same username and password. Thanks!

I pretty sure I type the same username and password to login SDK Manager post-flash installation dialog.
I logout my TX2 and than I login , So i’m pretty sure I type same password.
is the password need more than 6?

Hi vis51230,

Sorry, no idea why this issue happen.
Please try flash and setup again. Thanks!

Perhaps it is the login to NVIDIA failing and not the password to the TX2. The NVIDIA developer login name and pass might work if that is the case…versus the TX2 login.

Hi vis51230,

Have you managed to get the installation successfully?
Any result can be shared?

Thanks

I have the same problem with NvidiaJetson AGX. I have flashed the os and it is working, however, I cant install the SDK components. I have tried on different computers and different network but nothing worked.

Did you complete the first boot login setup directly on the Jetson? It used to be that accounts were pre-created, but now you have to add account names on first boot (you’d be prompted for this on the Jetson itself). SSH will fail if the account does not exist.

Thank you for your answer. I have set up the Jetson (connected to monitor and did the initial set up for os) and I correctly entered the Jetson user name and password on sdk manager however it gives me the same error.

Are you able to log in manually to the Jetson with keyboard/monitor directly on the Jetson? If so, then this should be working from SDK Manager. From your host PC, try to ssh to the Jetson, and log in via that name/pass…perhaps the first ssh session “ok” is getting in the way.

Do note that there are a lot of different ssh errors. Just failing to log in could be a number of things unrelated to actual correct flash. If you cannot ssh from host PC to the Jetson, then SDKM is guaranteed to fail. You can run ssh in verbose mode to get more details if the initial failure message is inadequate. However, for ssh from host to Jetson, what is the exact error message?

If this is not enough information, you could run “ssh -v yourLoginName@192.168.55.1” and see what that says (this is more verbose).

I couldn’t connect to ssh. I will try to reflash it. Thank you very much for your support.

If you can “ping 192.168.55.1” from the host PC, then probably there is no need to reflash. Assuming you did your first boot account setup, then you should be able to ssh to 192.168.55.1 and log in. If this fails, then you can try verbose to see an error log (this will save a log of the verbose ssh login attempt, but shouldn’t save passwords…you can delete any password if it is there):

ssh -v yourLoginName@192.168.55.1 2>&1 | tee login.txt

This is only needed if first boot login directly from the Jetson completed, and after this ssh fails.

If you hover your mouse over the quote icon in the upper right of one of your existing posts, then other icons will show up. The paper clip icon is for attaching files.

Hi, I spent hours to find the answer to this pb.
If you can ping 192.168.55.1 but can not connect via ssh, it may be because you are not using a qwerty keyboard on your jetson.
When you configure your jetson account manually on your jetson, your jetson keyboard is considered as a QWERTY keyboard by default ( it was at least the case for me), so the actual password of your jetson is not the one that you think it is.

Example: You pressed “azerty” as pwd on a AZERTY keyboard. But your actual password will be qwerty.