Blurry textures in RTX render

There’s an emissive text that is completely unreadable in my render sadly - I think I might have pushed my V-ram limit, but even when I’m rendering it out via movie capture it is still unavoidable - is there any fix so that this texture won’t appear unsharp in the final render?

Btw no matter how many samples i dump into either the Samples per pixels per frame, samples per pixel per iteration or path trace samples I still get a scene in which each frame takes 3-11 seconds to render and the results are quite blurry.

My last resort is to try batch-rendering it via the queue and farm systems, but I’m # 65.555 in that queue and it’s not getting lower

Man it’s such a bummer the text is blurry it’s a 2 minute long shot and this is the only thing that’s off omg

It looked really sharp when I was lighting and setting up, maybe I added too many materials and extras that dragged it down?

Hello @m.r.bjerre6715! I am contacting the dev team for more help here. You may need to send us your source file so that we can take a look at the settings. You can send it to us by email at

Hello m.r.bjerre6715

-In Extensions/Utilities/Statistics, you can get more info about memory usage. Can you specify what the number is for Virtual memory reserved for tiled resources? That would be indicative of memory usaged.
-Specify what GPU config do you have.
-Which RTX renderer are you using? RTX - Accurate (Iray) uses more memory, so you could use RTX - Interactive (Path Tracing) if you aren’t already which supports various optimizations such as texture streaming and parametrization for texture compression. Also, if using RTX - Interactive or RTX - Real-Time, one thing that could potentially help is to go in Render Settings/Materials/Texture Max Resolution and lowering that value to save some memory. It requires a scene reload for the textures to be downsampled.