Can’t flash Orin AGX timeout in USB write

Hello Nvidia team

I am currently facing an issue while trying to flash an Orin AGX 64GB developkit with Jetpack 5.0.2.

My SDK manager version is latest version, and I use USD 3.0 cable to flash.

I found below solution command and try it, but it doesn’t work…

Q: I get a USB timeout error during flash Orin. How to resolve that?

A known issue for ubuntu 20.04 host is the USB autosuspend function is enabled on it by default. This leads to Jetson recovery mode gets suspended before flash. To bypass this error, need to:

Disable autosuspend on host PC with below command:

sudo -s
echo -1 > /sys/module/usbcore/parameters/autosuspend

Plug out the USB cable, put jetson back into recovery mode again and plug the usb cable back.

If USB timeout is still there after above commands, please file a topic to forum and let moderator help check.

May I know the cause?
I tried Ubuntu 20.04 with a newly installed host pc, 2 host pc, but they all failed.
And I also tried to flash with other USB cables, but they also all failed and caused same problem.

I will attached the log file.

Thank you for reading my post.

SDKM_logs_JetPack_5.0.2_(rev._2)_Linux_for_Jetson_AGX_Orin_modules_2024-02-28_04-01-33.zip (113.7 KB)

The issue here is you are using the wrong Jetpack version…
Go and check which jetpack version starts to support Orin AGX 64GB first.

1 Like

Wow so sorry… I forgot there was a list of possible Jetpack versions… Thank you so much!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.